Joel's picture


I've successfully set up a joomla appliance on the hub.  I'm familiar with moving my Joomla site around, but when I tried to upload it and setup my site on my tklapp, it returns a 404 error.


Here's the steps I've taken so far:

1. gzip site directory on old server, upload to tklapp and unpack

2. do a mysql dump, create a new database with same user/pass on tklapp, import

3. modify joomla's config file to reflect new folder paths


At this point, I cannot access the Joomla backed. So I tried creating just a "hello world" .html file and put it into the directory. I cannot access that file, it also returns a 404 error.

I think I need to verify that the permissions are set properly.  So I tried to look at the working install of Joomla that came with the tklapp. I noticed that the owner of directories and files was www-data, where as mine was "20082"

So I guess my question is, what steps should I take so that a basic .html file is accessible in /var/www/test?

Jeremy Davis's picture

And the TKL Joomla appliance. But having said that, from what you've stated, I agree that it sounds likely that you have a permissions issue. The easiest way to go is make www-data the owner of the whole directory from /var/www up. This can most easily be achieved from the commandline:

chown -R www-data:www-data /var/www

And hopefully that should get you going.

Chris Musty's picture

Assuming the version you have is a TKL instance (ie 1.5, 1.6 or 2.5)

Run akeeba backup (free extension) on your site

Download the zip file from the old site

Upload the zip file to the new server

Unzip akeeba zip file on the new server

Run akeeba config on the new server

Ensure DNS, SPF and other hosting dynamics are set


Chris Musty


Specialised Technologies

Joel's picture

Well the first problem was that I did not understand how to connect the apache virtual server to a directory in Webmin. Once that was settled, I could then proceed to the next issue. One problem with the turnkey Joomla install is that the apache server has directory browsing turned ON by default. That's not good. Got that fixed, too..on to the next part:

Now I could access the directory, but got 500 error instead of 404. This was the permissions, and the ownership. By using the command below, I set the perm's to what Joomla needs to function.

I had to change owner of all the Joomla directories and files to www-data for user and group for the directory connected to the apache virtual server

I had to change permissions for files and directiories. I found this command to be very helpful:


find . -type d -print0 | xargs -0 chmod 0775 #for directories
find . -type f -print0 | xargs -0 chmod 0644 # For files
Joel's picture

Now that it's working, I was able to do some load testing.

I have to say, it's not good. Amazon ec2 small instance is extremely slow compared against my other hosting environments. (local and dedicated box with 3g ram, 2ghz dual core processor)

Poking around the reviews online, it appears that ec2 is better suited for applications that need to scale rapidly, as opposed to my web server req's of 100% uptime, serving about 3K non-static webpages per day. I didn't know this until now, but am glad to have gone through the process of setting up a server on ec2 so i could evaluate the service. 

the tklapp made it drop dead simple to evaluate ec2. I'm now considering using turnkeylinux, but on a dedicated box.


thanks to TKL for setting up the hub and the appliances, this was a fantastic way to evaluate amazon's service.

Add new comment