Eric's picture

I am running the live version in a VM. Whenever I browse to the server it redirects to a "cp" folder with a 503 error.

Manually typing in index.html retrieves the page in /var/www.

Version: turnkey-tomcat-apache-12.0-squeeze-x86.iso



Change /etc/tomcat6/mod_jk.conf from:

RedirectMatch ^/$ /cp


RedirectMatch ^/$ /index.html



Jeremy Davis's picture

There are over 100 different appliances...

But I see from your second screenshot that it is the Tomcat on Apache appliance.

So I have a couple of thoughts. Firstly, to serve html this appliance needs some tweaking. Have a look at the links here (the Tomcat on Apache Wiki entry).

Secondly Tomcat like lots of RAM, I suspect that thre reasoon why you are getting a 503 rather than the example Tomcat app ('cp') is because you have insufficient RAM allocated, or perhaps it just doesn't like running live? I would install it to a VM and make sure you give it at least 1GB RAM.

Eric's picture

You're correct. The 503 error was caused by a lack of memory.

As for the link, thank you. I believe that was what I needed. As for the required tweaking, shouldn't that be the default ability? I suppose I'm just a little surprised that I had to go through this to begin with that's all.


Thank for all your help!

Jeremy Davis's picture

If you have a suggestion on what you think would be a better intial config then I'm sure the devs would be happy to hear (although obviously no guarantee they'll take your advice). If you are particularly keen you could perhaps even create a TKLPatch!

I'm not sure why they pre-configured this one in the way they did, but I'm sure there was some logic behind it...

PS I just re-read your OP and I apologise that I missed your clear statement of the appliance you are using...

Eric's picture

haha no problem. I assume the default action to redirect to the control panel makes sense as a way for leading new users to where to go to change things, but it would seem that regardless of any changes they will always be redirected to the "cp" folder, as seen by the rule that's running in the config file.

In that case, I believe either something went wrong or I am doing something wrong. I usually think the latter, but assume it should be simple enough to tinker around in the server settings of the control panel to get it to work, and in this case I couldn't get it to work.

Add new comment