Jeff L's picture

Installed File Server - Simple Network Attached Storage - and was rather surprised when I got to the install updates stage to find out my network interfaces were not recognized.  I believe these HP's use Broadcoms.  Any suggestions?

Jeff L's picture

I know with a standard Debian netinstall I can have a usb drive with the firmware .deb file on it and the install will grab the firmware file and use it in the install so networking works. It appears the latest Turnkey install process does not do that as I did try it. When I copied the .deb to a completed Turnkey install and tried to run dpkg -i it would fail with casper script errors. Still looking for suggestions...

Jeremy Davis's picture

It sounds like your theory is correct in essence, but sounds like something missing...

I probably need a little more detail on the casper errors - in my experience casper errors shouldn't make any difference (casper is the live bit - so once you are installed then casper doesn't matter any more...)

So my suspicion is that something else is going wrong

Jeff L's picture

I had to get a fileserver in place fast - i.e. why I looked to TKL. 

As I was under a time crunch, I just installed Debian from a netinstall with the Broadcom firmware .deb on a usb stick attached to the machine when I booted from the netinstall cd and the installation went without issue and I have network connectivity. 

I quickly built my own file server, added samba, webmin, ssh, and ftp services.  Believe me when I say it is nowhere near as polished as the TKL fileserver, but I had to get something up FAST.  As a result, I do not have that hardware to test with as it is running in a production role at present with my Debian install. 

We do plan to move the file server duties again when new hardware arrives so I may be able to test on this HP DL380G5 with Broadcom nics in the future - which I will do as I know you need good feedback to be able to fix/address issues.

TKL rocks, just I could not take the time to troubleshoot it. I had to get a working solution in place ASAP.

Jeremy Davis's picture

And now you have it up and running I wouldn't worry about it too much now. Reality is that it probably wouldn't get fixed anytime soon, but it is useful to document this stuff to at least make other's exerience in the future easier...

Out of interest, I assume from your post that it was a thrid party/upstream firmware - or was it from Debian repos?

BTW why install direct to harware? I am unfamilar with your hardware, but a quick google suggested that whilst the range varies, generally you have quite capable hardware. So why not virtualise? Personally I think it is such a waste of hardware to install to bare metal - even if you don't currently have use for additional virtual servers.

My personal favourite hypervisor is ProxmoxVE (also based on Debian Squeeze - although with a RHEL kernel). It's super lightweight headless server with a powerful WebUI. It includes OVZ (Linux only) and KVM (any OS) virtualisation and integrates the TKL library into it's WebUI (ie you can download and install TKL to OVZ containers from within the UI). OVZ containers are brilliant and give you get near hardware performance.


Jeff L's picture

The firmware was from the Debian non-free repo.

We run a VMware datacenter, so I am well versed in virtualization and had actually used TKL Fileserver in that environment many times (along with other TKL appliances now that they are Debian based).  Encountering the issue installing directly to hardware was a surprise - something I have not encountered in some time due to our use of virtualization.  But this server only had a dual core processor and 2 GB RAM and was being installed at a customer site to tide them over until we can deploy their final solution.  All of our ESXi servers have a minimum of dual quad cores with of 16GB.

When we move them to their final solution, it will be virtualized and hosted in our datacenter.  But until then (need to get the fiber connection installed), they needed a solution onsite.  We will move this server to our data center to move their data into our VM environment - most likely to TKL fileserver.

I brought the issue up as it is one of the few times I have ever encountered an issue that could be tracked back to design.  I am guessing that the install process does not check other sources (like usb) for packages before launching the preseed install.  Debian by default will check other media sources for deb packages (beyond the cd it is installing from) when beginning the install process and that gives you the opportunity to inject hardware specific firmware into the base install.  Considering the netinstall uses the network - being able to add .deb's to the base install is important.

Jeremy Davis's picture

Yes the idea of looking for .debs on USB is a good one. I'm not sure hwy the devs skipped that? I guess it is not part of their custom loader/installer but perhaps they need to consider including it.

And sounds like you are all over virtualisation, although I would urge you to have a play with Proxmox if you get a chance. Perhaps it's not for you but when I was intially looking for a hypervisor (many years ago now) I did try ESXi but went with Proxmox instead. Since then the PVE devs have radically built on it. I have only a couple of single isolated instances so I haven't tried any of the more advanced features (such as clustering and HA) but they look pretty cool!

Add new comment