Chris Musty's picture

Hi all,

Have not had to ask any questioms for a while (except for a bit of prodding for sydney support in the hub).

I recently set up a prox server in a clients office so we could run side by side comparos of different databases, namely mysql, postgres, and nginx with an ide called real software.

To cut to the chase i downloaded the image through the tkl channel and fired up an ovz container thinking it would be as easy as ever.

For some reason when it fired up it went right into a bunch of updates and stopped dead with no response at  all i could type in the console but nothing was executed. Running turnkey-init or confconsole was fruitless. Thisbwas done through prox's java console not putty.

I tried another image and another all failing before i downloaded the iso and went full kvm.

Anyone seen this?


I went home after this and tried it there, two failed amd two workdd fine?!?!

Have had no time ti investigate... But will get into it over the weekend.

Any similar experiences?

Jeremy Davis's picture

I'm not sure if we are talking about the same thing as I have had issues but had them consistently (until I worked around it, and haven't tried the PVE Java console since - see last paragraph for details). I have been meaning to document this here on the forums for ages, so thanks for the nudge.

I was under the impression that this was a known (PVE/OVZ) issue with OVZ containers (as of v2.2 IIRC). I recall reading on the ProxmoxVE forums relating to changes in the PVE codebase (from OVZ upstream AFAIK) which now allow OVZ containers to have a 'true' console. The problem is that existing OVZ templates don't play nice with this. My understanding is that this makes the PVE Java console pretty much useless for TKL OVZs (and other existing OVZs - without a tweak to the container - which I haven't tried but I'm sure I recall reading about on the forums). The other thing is that IME unless turnkey-init is run the container, then SSH doesn't fire up so SHH isn't an option either.

So here's how I've been working around it:

Create a container, SHH into the PVE host, start the freshly created container, enter the container, run turnkey-init, start ssh and exit. The container will then function normally and be accessable via normal SSH connection. Eg OTTOMH (hopefluly I've got it right) for a container with VMID 100 (from within a SSH session on your PVE host):

vzctl start 100
vzctl enter 100
service ssh start

Add new comment