Forum: 
Tags: 

VMware: "Unable to connect to the MKS: Error connecting to /bin/vmx process."

Guest's picture

I am working with a group that is trying to run a VM we provided that is based on TurnKey Core 12.0. The VM was running until they upgraded from VMware 4 to 5.1. Now the VM fails to boot and gives the error: "Unable to connect to the MKS: Error connecting to /bin/vmx process."

They also tried importing the the TK Core 12.0 VMDK image from the TurnKey website and got the same error.

Has anyone run into this problem before, and is there a known fix?

Jeremy Davis's picture

Perhaps it's just because lots of people use it, but it seems that VMware has lots of problems... My personal solution would be to ditch it and go for a (IMO) better hypervisor like Proxmox, but obviously that's not actually solving this problem...  (Although it would solve the problem! :D)

A quick google seems like there are lots of possible causes/solutions to this issue (doesn't seem to be a consistent reason for this error message), ranging from DNS to corrupted HDD images... It seems that there were reports of this error prior to v5, but v5+ is extra fussy...

I'm not sure if this is at all related, but I recall that there were a number of people having issues with TKL on v5.01 when it first came out, but others (with the same version) weren't having the issue. IIRC it was eventually put down to a 3 way issue between hardware, VMware and TKL. But as the devs don't have VMware (and even if they did unless they also have the problematic hardware) it's nearly impossible for them to troubleshoot.

Perhaps searching/posting on the VMware forums you might get more ideas?

Brahim's picture

 

This worked for me ,  but I do not remembre the source

 

 

Resolution: Create a new VM with custom option with the same configuration but without any virtual disks. and then attach the existing the disks of the problematic VM in the proper order.
Make sure the problematic VM is powered off.

Root cause : vmx file is corrupt.

Radu's picture

I've just ended the vmware tools installed and it's working fine after that

Daniel's picture

Yes this worked for me!  Great find.

joginder Pal's picture

Windows7/64 VM: Unable to connect to the MKS: Error connecting to /bin/vmx process.

 

Resolution:   Please restart the main Host and they try I worked for me, hope it will help other as well.

Thanks,

Joginder ( 08587904910) IND

 

Dipti's picture

Unable to connect to the MKS:Error Connecting to  /bin/vmx Process

The Work around Soulution is below

  • vMotion the affected virtual machine to another ESXi host.-It is not possible as the VM backup is going on
  • Restart the virtual machine from the vCenter Server or ESXi host.As already one task is progressed we can not restart the VM and ESX can not be restarted as other VM are exists.
  • Restart the ESXi host:ESX can not be restarted as other VM are exists

Apart from these above solution is there any permant solution there.

Please Post.

Post new comment