Mike's picture

I followed your instructions the SSL blog and it worked great for the site, I'm using the Amazon Turnkey Lamp.

But now the webmin page gives this ssl error:

Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error

Also when I restart apache it gives me this error, which I guess is the cause of it:

 ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName

I modified the etc/hosts file to try to fix it and it does not work, maybe I'm setting it wrong or maybe I am going in the wrong direction completely. If you have any advice on how to get it working again, please let me know.

FYI- This is how I set the etc/hosts localhost crm.usalegalaid.net lamp crm.usalegalaid.net

#Required for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Chris Musty's picture

It seems your SSL cache in your browser is caching unwanted data.

Not sure where it is in ie, chrome and firefox but cant be hard to find.

Verify that is the issue by using another browser or PC.


As for the "Fully Qualified Domain Name" issue, what do you get when you type (comand line)



hostname -f

you can change the hostname in webmin or by typing

hostname myservername

and restarting networking, apache etc or even rebooting the vm.

There may be other issues but try that first.

Chris Musty


Specialised Technologies

Mike's picture

The SSL cache is not the problem because I have already tried from 2 other machines that had never previously accessed the server.

Mike's picture

Also I can get phpmyadmin with no errors, using the same domain https://crm.usalegalaid.net:12322/

Try it, you've never been there and see if you get the error:


Jeremy Davis's picture

phpMyAdmin runs on Apache so that explains why that is working fine.

Webmin has it's own miniserver built in. So now that you have changed the SSL cert I suspect that you'll need to configure that to use the new cert too... I don't know how though - I've never used a non-self signed SSL with TKL. I suspect that you should be able to find something via google on how that is done. (If you do, be great if you could post back about it and/or link to it - Cheers).

Also the Apache 'issue' you refer to is a config warning (as opposed to an error) and though it's probably still a good idea to fix it, it has nothing to do with your current issues... TKL comes with that warning as a standard feature! :)

Mike's picture

Is there a way I could do a self-signed cert for Webmin and keep the signed cert for the site?

Jeremy Davis's picture

But I would assume that if you left the original self signed cert as is, then that is how it would work by default, but I have no idea.

I suspect that you may need to have a fiddle and/or google and see what you can figure out.

Mike's picture

Could you tell me the path to the webmin server, maybe I could amend that to point to the new SSL cert. Do you know if it has a configuration file with a virtual host type of configuration?

Add new comment