Need help on this error

Jiger's picture

Hi all,

I have installed the TKL server having version 6.0.5

 

The server was running quite well until today when i noticed that when the webconsole of the server is tried to open the following warning is being displayed. I would appreciate if some of the experts out there can help me with this. Thanks!

 

Warning:

 

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<tree>
<message type="ERROR">
session_start(): open(/var/lib/php5/sess_vhu1isstd30gl2pep2p9f1ldl5, O_RDWR) failed: Read-only file system (30)
</message>
</tree>
Jeremy Davis's picture

I assume that you mean the webshell that you can access via https://<FQDN-or-IP>:12320?

Also I assume that when you say version 6.0.5 that is referring to the version of Debian that the appliance is based on (i.e. TKL v12.0)?

Where is the appliance installed? On hardware? On a VM? AWS/TKL Hub? If it's a VM - out of interest what virtualisation platform? VirtualBox? VMware?

Would I be correct in also assuming that when you say you are getting that error, that you are getting that error in your web browser? If so have you tried any other web browsers? (Not that I think it would make any difference...)

The fact that it is complaining about a "Read-only file system" is potentially a concern. If Linux detects harddrive corruption that is the most common reason for a file system to be mounted read only.

Can you connect via SSH (try PuTTY if you are on Windows or just use the commandline in Linux/Mac OSX with the command "ssh root@<FQDN-or-IP>". If you can, then test to see if the file system really is mounted read only by creating a file:

touch testfile

and see if it's there:

ls

Jiger's picture

 

Hi Jeremy,
 
Thanks for the response. Please find the required details as below:
 
Yes, by webconsole I actually meant webshell accessed via:
 
https://<FQDN-or-IP>:12321
 
Sorry, I am not a linux expert so not very good in linux terminology :(
 
Your understanding regarding the version is correct.
 
The appliance is installed on VMWare.
 
Yes, the error mentioned is being noticed while i try to open the webshell in the Web browsers. I have tried all the web browsers (IE, Chrome & Firefox). The error in all the browsers majorly remains the same.
 
I am able to connect to the appliance via SSH using PuTTY as well Winscp.
 
After, login to the appliance using Winscp from my Windows laptop via root account I tried to create a new file however I got the below error popup message:
 
 
Cannot create remote file '/root/New file'
 
General failure (server should provide error description).
Error code: 4
Error message from server: Failure
Request code: 3
 
Thanks,
Jiger

JN

Jeremy Davis's picture

And my suspicion is that Webshell not working are the least of them!

My guess is that your harddrive image has been corrupted. When Linux detects harddrive corruption it will only allow the disk to be mounted as 'read only' to maximise the chances of you getting your data out, without doing any more damage. Ultimately this is a good thing, but can make life awkward...

From my involvment here on the TKL forums VMware products in particular seems to suffer from this problem more than most. This issue is sometimes caused by hardware degridation i.e. on your physical harddrive; sometimes caused by closing your VM or host OS incorrectly (not using the 'shutdown' or 'halt' command from within the VM); or sometimes for no apparent reason...

Assuming that this is the issue, to resolve it you will need to run 'fsck' (Linux equivalent of 'chkdsk') on your VM filesystem. You can either use a Linux LiveCD ISO or mount your VM HDD image to a separate VM (as a secondary drive).

Apparently the Slax Linux LiveCD is known to work well (although theoretically any Linux LiveCD ISO should do the job - including TKL ISO). You will need to check what the drive/partitions is/are called with:

fdisk -l

and then run fsck on it/them:

fsck -y /dev/sdXN

where X is the drive letter (usually a or b) and N is the partition number. E.g.

fsck -y /dev/sda1

You will also want to fsck the LVM volume, like this

 

fsck -y /dev/mapper/turnkey-root

Hopefully then a reboot and you're all good again.

To make life a little easier in future, once you get the machine up and running, I recommend installing the acpi-support-base package to your VM.

apt-get update && apt-get install acpi-support-base

This will allow VMware to shut it down properly (without requiring you to do it from within the VM). The lack of this package has been recognised as a TKL 'bug' and will be included in future versions.

Post new comment