Mark Coleman's picture

I've been beating my head against a wall for the past two days- maybe someone can offer some clarity.


Downloaded the file server OVF template, deployed to VMWare ESXi server, turned on, established passwords, etc.  Accessed the ajaxexplorer via my browser (by navigating to the IP of the machine), logged in as admin, setup a user, made sure they had R/W access to the "test_diret" repository, logged in as that user and I cannot create folder or upload files.


Here's the error log info:

date ip level user action params


04-12-13 18:59:11 INFO serial-mark error message=url_stat(): dir failed for path '\\test_diret'
I also get this:
date ip level user action params
date ip level user action params
04-12-13 19:08:47 INFO serial-admin error message=Cannot create root path for repository (test). Please check repository configuration or that your folder is writeable!
It also sometimes tells me right after logging in that it can't find the user, yet it still logs me in.  I even tried giving the admin login permissions to R/W to the "storage" repository (and the "test" repository) and then logged in and tried to create folders and upload folders- no dice.
I've tried reinstalling it at least 3 times, I verified the md5 sum for the download, and as an IT administrator, I'm feeling really dumb!
Jeremy Davis's picture

Out of curiosity I just tested this (I've never used Ajaxpolorer on my fileserver before). Logged in as Admin (local user - not Samba) and created a new repo in /srv/storage/test. All worked as expected...

But I'm not running VMware (installed under OVZ in Proxmox)... IMO VMware seems a bit flakey... As a regular here on the forums I have had seen lots of people have issues with VMware TKL installs (although many others don't). I have tested TKL builds before on VMware (both VMware player and VMware Server) and only ever once had issues myself (it was HDD corruption, caused by not shutting down the VM properly...)

Perhaps might be worth trying to log in via SSH (or local sheel) and create the folder first and give global read/write access:

mkdir /srv/storage/test
chmod 777 -R /srv/storage/test

Then log back into Ajaxplorer and try to create a new repo within it...

Add new comment