Alex Wiley's picture

So, to start off, I'll say that I'm not too familiar with Linux, and not at all familiar with Turnkey. The reason I'm here is because I use MineOS, and the creator of it is abandoning CRUX in favor of Turnkey.


Anyway, I'm running MineOS Turnkey on an old Dell Inspiron 6000. I have to use a wireless connection, and I've already discovere that I'll have to install some packages to get that working. The problem is that when I use ethernet to connect to my modem (not the router, and I connect to the moem because I only have on working ethernet cable right now, the one going from the modem to the router, and I just disconnect the router and connect the Dell), I still connect to the internet. The error I get is "No lease, failing" from udhcpc, and that eth0 is not up. The cable itself is fine, and works perfect when I hook it back up to the router. Any help would be greatly appreciated.

Jeremy Davis's picture

So perhaps you'll need to set a static IP? You used to be able to do that from the Config Console but I've noticed since 12.1 that it doesn't appear now on AWS and OVZ instances... I assume that that is because it's not applicable to them (and that it would still work on hardware and other VM environments where it'd be useful). As long as your PC is on the same subnet as the modem it should work ok...

Alex Wiley's picture

I finally got an ethernet cable, and hooked the laptop up to the router, and that seems to have fixed my porblems. I installed the necessary packages (update and wpasupplicant) and confirmed that the commands for wpasupplicant are usable. But now I am having a new problem. Whenever I try to use wpa_supplicant, the configuration file cannot be found, and I tried wpa.conf and wpa_supplicant.conf as the configuration files. I also noticed that eth1 isn't showing up, which is the NIC that is for wireless, and the one I used on CRUX. I'm not sure if that is part of the problem, but I thought I would say it anyway. Any advice would be appreciated, and I do now have access to the internet on the machine.

Jeremy Davis's picture

With WPA supplicant as I have only ever used it on desktop OS and Debian/Ubuntu (and derivatives) have really got this stuff sorted out these last few years (except for some newer NICs needing external/upstream drivers).

In my experience the first wireless interface is usually wlanX (e.g. wlan0 not ethX). You may have already looked at it, but the Debian wiki includes info about configuring wpa_supplicant.

Alex Wiley's picture

The laptop that this is on uses an Intel PRO/Wireless 2200BG card. I didn't have any problems when I was running a derivative of CRUX, nor do I have a problem when I run Ubuntu off a flash drive on this machine. However, the only NICs that show on when I use the Turnkey dirvative are eth0 and lo. These are both wired, so even though I think I have my problem with wpa_supplicant figured out (didn't know that /etc/network/interfaces is the config file I needed to point to), I can't test this theory since I have no wireless controllers to use. I have tried both ifconfig and iwconfig, and there aren't any WNICs. I think that the problem might be that I need to install the drivers for the card, but I'm not sure, and I also am not sure how to do that, but that's not important right now (I think).

Jeremy Davis's picture

Although I have come across some stubborn ones... In my experience newer chips can sometimes be problematic and i have also come across some USB wifi sticks that refuse to work nice. Generally though wifi chips in laptops (especially older ones) are supported. I suggest that you go back to the Debian Wiki... (it'll be much easier if you use your wired connection while you do that).

Sorry I can't give yu specific instructions (it's been a while and I don't recall OTTOMH but the process goes something like this:

  • Find out wifi chip (probably using lspci command)
  • Find out relevant driver (google code/name)
  • (Hopefully) find the relevant deb firmware package to install (if not then you'll have to find the driver archive and build a module - a bit of a pain but doable...)
  • reboot
  • config your wireless...

If you get stuck, feel free to post back and I'll try to help.

Alex Wiley's picture

So I thought that /etc/network/interfaces was the config file, but apparently it isn't. When I try "wpa_supplicant -Dwext -ieth0 -c/etc/network/interfaces" I get the following:

Line 4: unknown global field 'auto lo'.

Line 4: Invalid configuration line 'auto lo'.

Line 5: unknown global field 'iface lo inet loopback'.

Line 5: Invalid configuration line 'iface lo inet loopback'.

Line 7: unknown global field 'auto eth0'.

Line 7: Invalid configuration line 'auto eth0'.

Line 8: unknown global field 'iface eth0 inet dhcp'.

Line 8: Invalid configuration line 'iface eth0 inet dhcp'.

Failed to read or parse configuration '/etc/network/interfaces'.


So now I'm lost. Any ideas?

Alex Wiley's picture

Also, I tried the instructions on the Debian wiki, and I'm definitely missing a network controller. All I have available are eth0 and lo. eth0 is a wired controller, and lo is something else, but definitely not a wireless connection. 

Jeremy Davis's picture

As I suggested in my previous post, it sounds like you may need to install a driver for your wifi. Step through the wiki page i link to above (and follow the links to other wiki pages as relevant)...

Add new comment