Michel's picture

It's been past 2 hours when trying to launch a new server, but it is stuck on "Installing security updates..." (see attached file)

It seems like other people are having the same issue for the past few days.

After another 2 hours, I will need to delete this server so I'm not charged for a Turkey appliance server that isn't working.

Please let me know when the issue is resolved or what I need to do?

Michel

Forum: 
Jeremy Davis's picture

If so try launching in another location (I launched a Small instance in California - US West instead and it worked ok for me). Apparently there has been some sort of complication with the TKL images when launched in the Sydney AWS datacentre. The devs are looking into it AFAIK.

However I did have some issues with a Micro Instance (it didn't get stuck 'Installing Updates' but it did seem to ignore the preseeded values from the Hub web form.

James Nobes's picture

As I'm located in Australia, this problem is a showstopper for me. Do you have any further updates or a link to a ticket that I can follow?

Thanks,
James

James Nobes's picture

I destroyed my instance that was stuck on 'installing security updates', and started a new one this time 32-bit rather than 64-bit. It deployed sucessfully within a minute or two. So I wonder if this is a 64-bit problem?

Here is a copy of the console log when it failed:

https://www.evernote.com/shard/s260/sh/a55b6b86-904d-4a36-81b3-05ffd7936...

James

Jeremy Davis's picture

But obviously not... Or perhaps it's another issue (with the same result)?

If it is the same issue as before (which seems quite possible considering your log) then it is to do with DNS not resolving (see Alon's post on the TKL Issue Tracker). I actually found that despite the Hub saying it was installing updates, it was actually running and functional (bar the DNS OOTB). Alon's workaround worked fine for me... It's a bit if a pain and not how it should be, but it should get you going (and once your server is up and running it should all be fine... I had no further issues after applying the workaround.

BTW I'll reopen the issue on the tracker...

[update] I reopened the issue on the TKL Dev Tracker and it seems that I was wong in jumping to the conclusion that it was the same issue. It seems it was a different issue...

Jeremy Davis's picture

I just tested an x64 Small appliances in Sydney and it worked fine. Did/can you try again to see if it works...?

James Nobes's picture

I ran up a 32-bit Wordpress after the x64 wordpress failed, and the 32-bit worked fine. I'm using that now and am only on the free plan, so can't add any more :)

Maybe try an x64 Wordpress appliance in Sydney and see if the problem repeats?

J

Jeremy Davis's picture

And it started fine... So it seems that it was an anomly...

Were you using a Small instance?

James Nobes's picture

Yes,  a Micro EBS-backed. OK, let's put it down to an anomoly - and thanks for checking!

Jeremy Davis's picture

Although really I should have known that... Your comment about you being on the free plan should have been a giveaway! :)

Anyway I'll test a Micro WP x64 appliance and see what happens...

[update] The x64 Micro WordPress TKL appliance booted and runs fine for me (in Sydney).

Add new comment