Frank's picture

Hi there,

I read a lot about people having trouble with hostname and the possible solution. I have the same issue in the following context but none of the proposed solution either worked.

We have turnkey solution in our vSphere cloud. Our cloud is a subset of our hosted corporated infrastructure meaning we have no control over what the company firewall could do.

Each imported turnkey cannot be referenced from another machine by its hostname (short of fully qualified named).

As mentioned I tried the different solution proposed on the turnkey site with no success. It means we are always dependent of accessing a VM through its IP address that can change at anytime.

The curious thing is that for validating this hypothesis of the appliance versus the corporate network we also installed VM from the following place : and strangely this VM's hostname was instantaneously visible by its hostname accross the network.

What is so special with turnkey appliance that they cannot send hostname to DNS ? Or may be they send it but the hosted infrastructure rejects it ?

If someone has any idea about this...



Jeremy Davis's picture

Is to give the machines static IPs and then configure DNS to point the FQDN of the server to the (static) IP. Just like how most of the internet works! :)

But it sounds like that isn't an option... I suggest you try installing Avahi (AFAIK it's what Ubuntu uses, hence why the other images you tried acted as you hoped). Debian (the basis of TKL) does not include it by default...

apt-get update && apt-get install avahi-daemon avahi-discover libnss-mdns

I'm not sure but I don't think it requires any config, but I'm not sure...

Frank's picture


the problem is still there and avahi (with no config) by default did not solved my issue. But it allowed me to see by what name the VM was known from the corporate network. Considering my VM has a hostname = fileserver and following avahi directives, I can internally ping it as : fileserver.local. By doing this the ping returned something like 64 bytes from (

So I cannot externally ping it as but it works as which is not an elegant solution for a human readable hostname.

I still have no clue a VM is 'plug-and-play' when it's not a turnkey VM (any turnkey machine has this problem). It may be a corporate firewall that see it as an 'intruder'.

I gonna look in much more details avahi but I consider the turnkey is not welcome in our network. At least it workk with a name provided by the corporate network. As a work-around I also used ddclient to have a fully qualified name but of course it uses externnal resources.



After many research the conclusion Icame to is that turnkey machine are not recognized on our Windows Domain. This is why they get a hostname provided by the infrastructure. ubuntu ones have this feature and it explain why I can reference them with a hostname. i,ll see with our network admin the reason of the rejection.


Add new comment