Bart Degryse's picture

Dear,

I have just installed the postgresql virtual appliance in VirtualBox. The installation seemed to go fine.

When I go to PHPPgAdmin I have no trouble loggin in with the postgres account and the password I set during the first run.

When going to Webmin or Web shell however I can't login with the root account. I've also tried the postgres account but to no avail.

What can I do to fix this?

Thanks for any help

Bart Degryse

Forum: 
Jeremy Davis's picture

So just like the PostgreSQL password, you should have also set a root password on firstboot.

To log into Webmin and Webshell the username is 'root' and the password that you set. In Webmin asterisks or dots should display in place of the characters, in Webshell nothing will display as you type your password...

Assuming that you have all that under control and you are still having issues, perhaps double check that you have a US keyboard. If not then that may be the issue as the VM will have interpreted the keys incorrectly, but the browser will interpret them correctly (so from the perspective of the VM the password you first entered and the one you are trying to use to log in are different). Therefor it may be just fluke that the characters in the password you used for PostgreSQL were correct both ways but not for the root password (unless you used the same password in which case I have no idea...)

The other possibility is that there are some characters (i.e. special characters) in your root password that the VM isn't reading correctly.

So assuming that you don't have any data in there, I would recommend that you just start again (you could reset the root password but it's easier to just start again IMO). Then depending on which of these you think may be your issue try setting simpler passwords initially and reset it within Webmin or Webshell once you're up and running. (And if you don't use a US keyboard set that up prior to changing the password).

Any general Linux/OS stuff you should be able to find more info for via Google as long as you keep in mind that TKL v12.x is based on Debian Squeeze (aka 6). Also feel free to post back any info you find that others may be interested in. Perhaps you might make things easier for someone else in the future! :)

Bart Degryse's picture

Thanks for the answer, Jeremy.

Reading through your answer made me realize what I've done wrong. I did set a root password but I'm not using a us keyboard. When trying to login to Webmin and Webshell I did take that fact into account so I "corrected" the "a" in my password (which would be the "q" on my keyboard). I didn't do the same for the "z" however ("w" for me). Simply forgot that was a special one too.

I'm not at home right now, so I can't try it, but I'm pretty sure that will solve my problem. Thanks!

Wouldn't it be possible to avoid this kind of problem by letting the users set the correct keyboard during the first run?

Best regards

Bart

Bart Degryse's picture

It works, Jeremy.

How can I change the keyboard layout? I've looked in Webmin, but can't seem to find an option to do that.

Jeremy Davis's picture

So either login via SSH or Webshell...

The Debian Wiki suggests:

dpkg-reconfigure keyboard-configuration

(TKL v12.x is built on Debian Squeeze; TKL v13.x will be built on Debian Wheezy)

However I can't confirm that... Google had alternative suggestions too so if that doesn't work for you have a google and see how you go! :)

philip.daniels1971's picture

That still works in Wheezy, I was doing it yesterday with one of your Release Candidates. You can change the font as well if you want, I like Terminus.

http://www.turnkeylinux.org/forum/support/20100707/uk-keyboard-mapping-problem

Jeremy Davis's picture

Nice one! :)

Bart Degryse's picture

Despite what is said in the forum topic Philip is pointing to (and which I had found already myself) it doesn't work. When issuing dpkg-reconfigure keyboard-configuration or dpkg-reconfigure console-setup in the webshell I get these responses

Package `keyboard-configuration' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: keyboard-configuration is not installed

Package `console-setup' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: console-setup is not installed

Am I doing something wrong? Or do I have to install something extra first?

I found this topic: http://forums.debian.net/viewtopic.php?f=30&t=49129 and tried the mentioned apt-cache policy keyboard-configuration command which gives me:apt-cache policy keyboard-configurationapt-cache policy keyboard-configurationapt-cache policy keyboard-configuration

keyboard-configuration:
Installed: (none)
Candidate: 1.68+squeeze2
Version table:
1.68+squeeze2 0
        500 http://cdn.debian.net/debian/ squeeze/main amd64 Packages

I learn from that response that it's not installed, but as I don't know any debian it doesn't tell me what to do next. So I searched further and found this: http://pkgs.org/debian-squeeze/debian-main-i386/keyboard-configuration_1...

So I did a apt-get update and apt-get install keyboard-configuration which finally got me into "package configuration" where I can choose a keyboard. For Belgium I find 8 layouts, but I haven't the faintest idea what the difference between those eight is.

If anyone knows of a site where those eight are visualized: that would be very helpful.

Bart Degryse's picture

After I ran the apt-get install keyboard-configuration command I got to choose a keyboard layout based on country. Since there were eight and I didn't know the difference I chose the first one thinking I coul always come back and choose another one.

I issued /etc/init.d/console-setup reload and started trying all of the keys on my keyboard. Soon I found out several didn't give the expected result. So I ran dpkg-reconfigure keyboard-configuration again to try another option. Unfortunately this time I don't get a country based list, but one based on brand and model. And of course, mine is not in that list. So how do I get back to the country based list? Surely not by issuing apt-get install keyboard-configuration. This time it only tells me:

Reading package lists... Done
Building dependency tree
Reading state information... Done
keyboard-configuration is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 
Jeremy Davis's picture

Well TBH I have no idea (I'm in Australia and we use the 'standard' US keyboard here) and TBH I would have expected that the dpkg-reconfigure keyboard-configuration command would have taken you back to the same options... But obviously not!

What you could try is reinstalling the package:

apt-get remove --purge keyboard-configuration
apt-get install keyboard-configuration

And that should at least take you back to the same config options you had the first time (the --purge switch should remove any config file associated with keyboard-configuration).

But as for your initial problem I have no idea... Have you consulted the Debian Wiki (as I suggested)? It looks like that has a fair bit of info... Also google suggested that this blog post may be helpful. It's quite old but suggests that

dpkg-reconfigure console-data

might actually step you through working out which keyboard to select... Might be worth a try? You may also need to install this first though...?

Bart Degryse's picture

I've spent hours and hours testing different keyboard layouts but none seems to show on screen what I see on my keyboard, even though in Belgium this is just a default, everyday keyboard. So I give up. Once again I'm disappointed in *nix (whatever the distribution). If *nix ever wants to do better than Windows things like this should be handled far and far easier. In Windows I give my country and my language (nl-be together) and my keyboard just works. In *nix I read half the internet, spend too many hours and it still doesn't work. Too bad!

Thanks everyone who had suggestions on solving this. I didn't solve my problem but I appreciate the effort anyway.

Jeremy Davis's picture

Well that sucks mate... :(

Sounds like you've had enough! And rightly so IMO, although TBH it seems strange to me that a 'normal' Belgium keyboard isn't a whole lot easier to get going...

I know you've had enough, but as a final shot (or for someone else reading this who's not as frustrated and over it as you) perhaps it's worth a post in the Debian forums?

I'm sure that there must be a way to do this... Surely there are plenty enough Belgium Linux/Debian/Ubuntu developers out there to have resolved this in the past...!?

Anyway, thanks for your appreciation, even though we couldn't get you going...

Bart Degryse's picture

It is strange. I've had Ubuntu installed in the past. They offered the same choices and one of them actually worked. If only I could remember which one.

I might try the Debian forums as this is obviously not a Turnkey problem. Do you have the url of a good forum? I don't see one on http://www.debian.org/support

Add new comment