Barry Block's picture

I'm using the Wordpress appliance (TKL 12.1), running from a live-CD.  I'm unable to access the RSS feed for the running wordpress site.  On the main page of the site is the link, "Entries RSS".  If I click on it, I get the following error:

XML Parsing Error: XML or text declaration not at start of entity
Line Number 4, Column 1:<?xml version="1.0" encoding="UTF-8"?>

Of course, what should be displayed is the list of wordpress posts.  Note that I've not made any changes to the wordpress site--I haven't installed any plugins or made any other changes.  I've simply booted into the appliance and from another computer, brought up the wordpress site in the browser.

This error seems to be relatively common for WP and supposedly it's caused by blanks or blank lines existing outside of the "<?php" and "?>" tags in a .php file somewhere...  I ran a bash script to remove all leading/trailing whitespace and delete any blank lines in all of the .php files found under the wordpress directory, but to no avail...  The problem still exists.  Anyone else having this problem with the WP appliance?  Anyone know how to fix this?  I'm trying to debug the same problem caused by my WP plugin (on a production site) but I can't debug the error on the TKL appliance because, by default, the TKL appliance produces a similar error.

Any help is much appreciated.

Barry Block's picture

I ended up effectively working around the problem by simply not using TKL.  When all else fails, just roll your own!  ;-)  I simply booted into a Linux Mint 15 liveCD (Mate edition) and installed LAMP + phpmyadmin + Wordpress on top of it.  The RSS feeds worked right out of the gate and I was therefore able to install my Wordpress plugin and debug the problems it was causing to the feed (which turned out to be really simple given that the latest Wordpress version tells you during activation if a plugin causes problems to the RSS feeds). 

For the benefit of others, I created a short tutorial here:

"Now get this honky, you go tell Raphael that I ain't taking no jive from no Western Union messenger..."

Add new comment