John Draper's picture

When I go to my Turnkey Django page at,   you can try it also,  I get...

(1045, "Access denied for user 'django'@'localhost' (using password: YES)")

I setup my Database server as follows.

I created a database called "tracker",  under the user "django".  Seemed obvious to me.

I went to Servers --> MySQL Database server  - clicked on "New database" gave it a database name of

"tracker".  I never created any tables for it yet,  since "synchdb" was supposed to do that,   according to the Django documentation.   But before running "synchdb"  I went into MySQL Database server page --> User permissions --> From the list on top,   I checked "Django" and clicked on Django to bring up details on that user.   Under "Password",  I checked the "Set to..." radio button, and entered my password,  then I selected every item in the following table, then set everything to "Unlimited", and set "None" to certificate type, then saved.

Then,  I did...   

python syncdb


After struggling for hours and hours fiddling with the "" ENGINE dictionary specification,

This is what seemed to work.

    'default': {
        'ENGINE': 'django.db.backends.mysql', # Add 'postgresql_psycopg2', 'mysql', 'sqlite3' or 'oracle'.
        'NAME': 'tracker',     # Or path to database file if using sqlite3.
        'USER': 'django',                # Not used with sqlite3.
        'PASSWORD': 'password',            # Not used with sqlite3.
        'HOST': '',                        # Set to empty string for localhost. Not used with sqlite3.
        'PORT': '',                        # Set to empty string for default. Not used with sqlite3.

I went up to my SQL Database main menu,  looked for Tracker,  and presto,  the tables were there.  At this time,  I had spend 2 days so far,  getting this setup.

I verified I could start the Dev server,  it worked just fine.    My next step was to create the App.  I did this by executing the command...

python startapp trackerApp

Now,  I have a trackerApp,  with some additional directories it created.   WOW - this part worked just great.  

Next,  I wanted to now see whether or not I can use Administration page to control access to my Django Admin page,  to setup Django users,   and such...   But this is where everything went horribly wrong.

I got a Server Error.   Checked the server logs and ran into this access denied thing.   So I hit the forums to read of others having this problem,   but managed to get better diagnostic information by doing this...

One posted message said...   apache server -> global configuration -> Configure Apache Modules -> enable rewrite.   Next,  I tried the Administration page and I get this huge output.   It is very long,  but if anyone wants to look at it,   just email me at "", and I'll be happy to give it to you.

Ok,   so by this time,   about 3 days have been spent,  getting nowhere,  and I tried just about every suggestion I could come across,  but my reading speed (sigh) is about 1/10th a normal persons speed,  so I have in no way seen all of these so called solutions by I checked the most recent first....   and tried every suggested fix...   to no avail.   I'm totally out of options....   you have my site URL,    feel free to email me your PGP key,  and I'll send you the Admin passwords if you want to go into it yourself,  or better yet,  if you give me a time (UTC preferred please),  when you are free to vid conference with me using Fuze....  go to to download it....   it works on any platform including iPad,  Android, and almost every desktop.  It does what Skype USED to do before Microsoft bastardized it.

My time zone is UTC - 8 (pacific Daylight time).



Add new comment