Vicosmola's picture

Hi guys,

I am running proxmox 3.2-2, I tried Piwik 13.0-1 => everything worked correctly (also the wp-piwik plugin integration into WP cms).

BUT! :)

After maybe 2 days the piwik server was unreachable (ERR_EMPTY_RESPONSE).
This happened 2 times (the past 2 weeks). At first i just removed and created a new CT in proxmox.
Now I wanted to restore a backup - got an error "Unexpected EOF in archive" and "Error is not recoverable: exiting now" => this is a proxmox archive error, but nevertheless im sad, because I lost my data from the CT. (I dont know if webmin worked - and cant try now since the restore archive is corrupted and the CT was deleted before the restore operation => nice!...)

I noticed a big difference in the memory consuption - when it was working it was about 400MB, when it died it was about 100MB... so something was not running. (duh!...)

I tried updating the CT, rebooting, restarting the individual services... nothing helped.

In both cases i made a guest user with viewing privileges. (maybe about 5 users may have tried it?... there were 20 visitors to my watched page in total)

Both tries were around the "heartbleed" bug - could some updates have done this?
I dont think someone hacked/crashed it on purpose.

Any ideas? Has someone encountered this error before? You can easily test it by setting it up and waiting 1/2 days... :)

Thanks for any suggestions in advance gyus!

Jeremy Davis's picture

Firstly sorry for delayed response... I actually started replying days ago but never quite got there... FWIW I now have a CT of TKL Piwik v13.0 running on my PVE (v3.1) server so I'll keep you posted on how that goes...

When you say that you've tried restarting services etc, did you get any errors or warnings? Is there anything in the log files (I'd be looking for Apache and MySQL log files in /var/log) that might give any clues to what is happening?

TBH I'm not that familiar with the Piwik appliance so I can't really offer any immediate suggestions... Have you got any hints on what settings you've changed and anything else you've done so I can try to recreate your issue?

Also FWIW if you want to recover the data, don't delete the CT. I suspect that the data is all still there so it should be recoverable...

[update] I found an old Piwik bug which may contain some useful info in helping you get to the bottom of this... My suspicion is that it is to do with permissions... Also FWIW my Piwik server has been running for a couple of days now and still works ok. I have just updated it to the latest version (via the link in the browser window) and it still seems to be fine...

Vicosmola's picture

Hi, and thank you for your reply!

- i got no errors or warnings when i restarted the services
- log files are gone since the whole CT was deleted during the restore process
(I wanted to restore a *.lzo backup, and the process deleted the CT and THEN started to verify the archive integrity - which was corrupted... but the CT was already deleted... - not sure how to recover from this so i made a new CT (maybe there is a way? - I didnt look for a solution on proxmox forums...) )
- I used Piwik "out of the box" => easy mysql passwords, easy admin pass:
1. first try: I added a second site to the example site (my site name)
2. second try: I changed the examle site to "my site"
In both cases i changed the currency and UTC time and added a Guest user with easy password, and lastly changed the default display from yesterday to today...
I think those are all the changes i made...

I created a new CT with Piwik today, i tried to update it => "You are using the latest version of Piwik!"
So I tried this:
- CHMOD 0755 didnt work (i havent tried CHMOD 0777 - next time i will)
- manual update worked! (to ver 2.2.0)
- good find with the bug report (just a note: neither the wp_piwik plugin in wordpress wasnt working...)
- can you please tell me about your successful automatic update? I have the server behind a router with only one port forwarded to the piwik server in proxmox (port 3450 to port 80) - does the updater need some specific port forwarded, or is there a issue with some permissions? (can the permissions be the problem with the update and also the error issue?...)

Well im curious if it will work after this update. If not, I will try to play with the permissions. I will also make a backup from the current CT. If something happens, Ill post the logs here.

Thank you very much for your ideas and hints! Ill be back with a status update in a few days. :)

Jeremy Davis's picture

And it worked... Not really much more to say about it... Sorry that's probably not hugely useful but honestly that's all I did!

Also FWIW my Pwik server is going fine... I haven't actually configured it much so perhaps there is some bug somewhere that doesn't rear it's head until a certain specific set of settings are made... However it sounds like you didn't do much in the way of config before your error occurred.

Also FWIW in Proxmox the CTs can be manually backed up really easily. Just copy /var/lib/vz/private/<CTID> somewhere (preferably while the server is stopped) then you can restore it by copying it back in. AFAIK the builtin PVE CT backup does a similar thing, although it uses tar to compress the container contents! AFAIK tar can safely be used to compress a running CT (as can rsync) although IMO a stopped CT is ideal.

TBH I would be looking at the PVE host for issues. I had a PVE host some time ago that did strange things with CTs (VMs were fine). I noticed that using tar compression (gz or bz2; both compressing and uncompressing) both on the PVE host and inside CTs would sometimes result in failure or corruption. Sometimes copying large files would also error (it even caused a kernel panic on one occasion). After spending a fair bit of time trying to troubleshoot the issue (and coming up blank) nearly 3 years later (after working around the issue, then upgrading the hardware and re-purposing the original hardware) I discovered that I had a bad stick of RAM!

Add new comment