Kevin's picture

Tried adding a new user  ( >adduser --system  nobody)  so that I can use this VM in my Jenkins CI builder.


It seems to have taken it - no fails or errors


But I can't su into it:

root@tkldev ~# su - nobody
root@tkldev ~# whoami

I also can't log in to the same system I am already logged into as root.   It seems that root can be the only user for TKLDev.



Liraz Siri's picture

Hi Kevin,

This isn't a TKLDev problem, its a system configuration problem. In Debian "adduser --system foobar" gives user foobar /bin/false as a shell, which won't let you su.

If you insist on using the --system flag, you'll need to run chsh afterwards:

root@core ~# adduser --system foobar
Adding system user `foobar' (UID 104) ...
Adding new user `foobar' (UID 104) with group `nogroup' ...
The home directory `/home/foobar' already exists.  Not copying from `/etc/skel'.
root@core ~# chsh foobar -s /bin/sh
root@core ~# su foobar

I'm not sure I understand what you're trying to do, but for what it's worth the TKLDev build process relies on having root privileges inside TKLDev.

Add new comment