Per-Ola Mård's picture

Hello TKL brains,

Perhaps this is a stupid question, but I will take the risk. I am running a TKL core virtualized under KVM. As I am trying to install KVM on this TKL machine I run into problems;

apt-get install kvm<return>

after many many lines we puke like so:

Setting up qemu-kvm (1.1.2+dfsg-6+deb7u3) ...
[FAIL] Your system does not have the CPU extensions required to use KVM. Not doing anything. ... failed!
Setting up kvm (1:1.1.2+dfsg-6+deb7u3) ...
[master 287817c] committing changes in /etc after apt run
 27 files changed, 1470 insertions(+)

Is there a way to run KVM under KVM, or no?

Please advice.




Jeremy Davis's picture

But I have been unsuccessful in doing on my Proxmox server. From my research there are 2 requirements:

  • A CPU that supports it (IIRC it requires more than the normal 'cpu extensions').
  • A version of KVM (on your host) that also supports it.

When I tried to get it working I only managed to break KVM and no KVM VMs would boot... So beware if you have mission critical VMs running on the same host!

I don't recall what needed to be done but FWIW it's called "nested virtualisation' so google should head you in the right direction... Basically you need KVM to present the host CPU (or a vCPU that includes the cpu extensions) to the VM.

Per-Ola Mård's picture

Hi Jeremy,

Thank you for your reply. I have suggested for Scale to open up for this feature in future releases of their firmware. My understanding is that it is currently not posiible.



Add new comment