Sébastien PRODHOMME's picture

Hi,

I installed TKLDEV with Proxmox and tried to install Minecraft server. I searched a lot in documentation but it failed...

So, I tried to install Core on /turnkey/fab/product as described on documentation :

cd /turnkey/fab/product/
git-clone https://github.com/turnkeylinux-apps/core
cd core
make

Error message was :

Makefile:3: /turnkey/fab/common/mk/turnkey.mk: No such file or directory
make: *** No rule to make target `/turnkey/fab/common/mk/turnkey.mk'.  Stop.

So, I installed common on /turnkey/fab to use turnkey.mk and now I have this message :

make: *** No rule to make target `/turnkey/fab/bootstraps/wheezy', needed by `build/stamps/bootstrap'.  Stop.

Sure there is something I don't understand but I don't know what it is. Is someone can help me, please ?

Regards,

Sebastien.

Forum: 
Jeremy Davis's picture

Have a read here. The next version of TKLDev will come with all this stuff preconfigured to make it easier to get started.

Sébastien PRODHOMME's picture

Thanks, Jeremy. I understand better now... Turnkey is a great project and I appreciate it because I can remember time when I was a (real) geek. ;-)

I understand you should have a lot of work but could you tell me when your next version of TKLDev will come ?

I tried to make core but it failed :

cd core
make

  File "/usr/lib/python2.7/dist-packages/executil.py", line 66, in getoutput
    raise ExecError(command, exitcode, output)
executil.ExecError: non-zero exitcode (1) for command: useraufs-mount '--udba=reval'  'build/bootstrap'  '/turnkey/fab/products/core/build/.deck/levels/e87cdfad8e8fb4dbb196fb30b6b29361'  '/turnkey/fab/bootstraps/wheezy'
mount: unknown filesystem type 'aufs'
fatal: non-zero exitcode (32) for command: mount -t aufs -o 'dirs=/turnkey/fab/products/core/build/.deck/levels/e87cdfad8e8fb4dbb196fb30b6b29361:/turnkey/fab/bootstraps/wheezy,udba=reval'  'none'  'build/bootstrap'
make: *** [build/stamps/bootstrap] Error 1

Could you say me why it failed ?

Regards,

Sébastien.


Jeremy Davis's picture

Hmm that's weird. Can't say I've seen that one before. I'll download TKLDev ISO and set it up from scratch again and see if i can reproduce your issue.

Jeremy Davis's picture

And although it's quite old, I'm 99% sure I know what is going on...

AFAIK OpenVZ containers do not support AuFS internally. And I didn't tweak originally but my guess is that that's what you were using... I know it's nowhere near as convenient but if you install into a KVM VM (instead of an OVZ container) it should all work OOTB!

Sébastien Prodhomme's picture

Yes, I used OVZ container. I don't try now to installe a KVM but I'm sure it will be ok.

Thanks a lot and have a good year 2015 !

 

Add new comment