Eric's picture

After installing TKL File Server 13, system will not boot hard drive and goes into the UEFI Bios. At first I thought it might be the UEFI and tried several settings there. Then I thoguht it might be a flaw in TKLFS and installed TKL Domain Controller 13 and got same result.

Since TKL is Debian/Ubuntu based I then installed Debian 7, Ubuntu Server 14.04 and Linux Lite. All of these booted normaly after installation.

All things being similar (Debian based), why will TKL not boot after install?
Is there  anything I can do to fix this issue?

Motherboard is an ASUS B85M-E/CSM with latest BIOS installed.  CPU is Itel i3.  Hard drive WD 2G red.  4GB ram.

 

Thanks
Your assitence is appreciated.

Forum: 
Jeremy Davis's picture

And yes TurnKey is Debian based (v13.x = Debian Wheezy/7) and we do not compile our own kernel, grub or anything much actually (we have a few custom packages and a few things removed)... But TBH, I can't think of anything that should affect booting and give the behaviour you are experiencing...

Did it reboot ok during the install? Or was that where the problems started? I assume from your post that it reboots ok during install, but after it's finished then it won't. Perhaps it's an update to grub or the kernel (or something else boot related). TKL will want to install security updates as the final step of setup (do you let it do those?) Whereas default Debian won't do that and will require manual install of security fixes. FWIW for the purposes of testing stuff like this, Ubuntu is a different beast to Debian (and therefore TKL too) as they compile their own kernel - and it's probably a different version to the Debian one anyway...

Off on a tangent; it's not really an answer to your question (and may not even resolve your issue), but IMO installing to bare metal on that sort of hardware is such a waste. Have you considered installing a hypervisor such as ProxmoxVE (also Debian Wheezy based - with a neat WebUI) then install other OS as VMs (or containers actually for TKL). I have a 6yo Core2Duo running my Proxmox server at home and have TKL Fileserver running as a container on that (I also have about 20 other server VMs that are in testing or use). I actually have a separate HDD for all my stored files to live on (which I then mount to my Fileserver VM). This allows really easy upgrade/reinstall of the Fileserver OS without having to copy all the files across to the new OS. It also provides opportunity to install other appliances (for testing or use) and means that I can install software and muck around with settings to my hearts content while my Fileserver hums along happily - even if I completely destroy something in one of my other servers!

Eric's picture

Jeremy, Thanks for the reply.

Yes, it did reboot during install but not after.  As for the security updates, the option does not appear during install.  It does appear during first boot after password entry.  I verified this on a quick install on another machine I have handy.

As for the tangent, I'm looking at TKLFS in a work environment serving 70 users, so may not be too much overkill but your suggestions are welcome.  I have also recently started thinking about virtualization so I will definitely take the suggestion to look at PromoxVE.

Richard's picture

Hello,

Installed TKL 13 Bugzilla amd64 on a standalone i5 DELL, it will not reboot during or after installation.   If I force a power down reboot then it stops at the confconsole screen, if I exit the confconsole if freezes with the Do you realy want to quit screen, Yes|No with Yes highlighted.  The only key sequence that has any effect is CTRL, ALT, DEL upon which it completes a shutdown then freezes at [  676.257970] Restarting system.

Any ideas?

Installed TKL 13 Bugzilla i386 into a VMBox running on an i7 DELL, works as expected.

I will install the i386 version on the standalone i5 DELL as a test.

Any advice will be appreciated,

 

Richard

Installed TKL 13 Bugzilla i386 into my standalone i5 DELL, and it works as expected.

Jeremy Davis's picture

Or perhaps the wrong one(s) being loaded by default. But it's really only a wild guess... If you keep in mind that TurnKey v13 is a customised Debian Wheezy headless server then you may find some info associated with your hardware online...

FWIW IMO there are 2 things to consider:

Firstly running TurnKey on bare metal hardware is a complete waste of resources IMO. Unless you anticipate your server having phenomenal load, installing a hypervisor (Proxmox is my favourite) you will be able to run multiple TurnKey servers no worries (I have a 7yo Core2Duo running about 20 low load OVZ TurnKey servers - all like they were on bare metal...).

Secondly, even if you persist on running it bare metal; I would anticipate that you wouldn't want to shut it down/reboot it very often (once per year is probably the most I would anticipate). So whilst not being able to shut down nicely is not ideal; it is hardly going to be a big issue...

Also it's a bit late now; but for future reference you are probably better off starting your own thread rather than hijacking someone else's (that's good general forum etiquette; not just here on TurnKey). Unless it seems like you are experiencing exactly the same issue as the OP; and even then it's probably still better to start your own thread and post a link back to the similar thread (and perhaps post a link to your thread in the similar one...). Not a big deal, but it makes things much easier. E.g. I initially though that you were having issues with your server booting after install (as per the OP's problem) but it turns out your issue is completely different...

ha11oga11o's picture

Sorry for opening this post after all this time but...

I have exactly same issue with Stable version: 15.2 . Cant believe it still problematic. Any other distro works but this one simply wont boot after first reboot.

 

Trying to install it at dell Wyse zx0

 

Cheers!

ha11oga11o's picture

Sorry i made mistake instead reply i made new post. Im reffering to this

https://www.turnkeylinux.org/forum/support/20141017/tkl-does-not-boot-af...

 

Cheers!

 

Jeremy Davis's picture

TBH, my guess is that your issue (and perhaps even the original issue now I reread this thread) is UEFI. Currently TurnKey does not support UEFI, only legacy BIOS.

I agree that that is not ideal, but in context it's worth pointing out that 99% of TurnKey users run TurnKey as a VM. Either remotely on some VPS platform (using virtualisation platforms such VMware, KVM, Xen, OpenStack, etc) e.g. AWS, or locally within a hypervisor such as VMware vSphere, ProxmoxVE or OpenStack, etc. Many developers and home users often run it via a desktop VM platform such as VirtualBox or VMware Player. Because of that, we focus most of our efforts towards those platforms, rather than hardware.

So how do you work around that? Well, AFAIK it should be possible to configure your hardware to use legacy BIOS, rather than UEFI and that should get you up and running. Although I'd argue that other than specific circumstance (e.g. really high load usage; or low resource hardware), running TurnKey on bare metal hardware is overkill and a waste of hardware resources. Especially on powerful purpose built server hardware.

Whilst you do create a degree of redundancy running everything as VMs, IMO the redundancy is a plus. It gives far greater flexibility and allows you to separate different services into their own VMs. So whilst there is still a potential risk that the hardware itself will fail and bring down everything, there is less chance of the failure of an individual service bringing everything down.

So personally, I would encourage you to install some sort of hypervisor on your hardware (Proxmox is my favourite), then install TurnKey as a VM.

If you'd prefer to persist, I'd suggest you have a poke around and see if you can enable legacy BIOS mode.

Having said all that, we do hope to support UEFI at some point, but there is no ETA and we already have a mile long todo list so no idea when that might actually happen...

If you have the skills and knowledge to work on this, we'd be happy to accept a pull request (although probably best to discuss it with us before you spend too much time on coding). Alternatively, if you don't have the skills and knowledge but would like to see this pushed ahead, perhaps consider offering some sponsorship to ass this feature?

Add new comment