Dom's picture

Hi all,

Ok, I have been using Bamboo for a long time and it has been great I luv it. It runs as a vm on Esxi 5.1 (free) I have made the domain changes in vsphere client to have the new domain etc.

Added DNS A record for my bamboo servrer, can ping by name etc. Made sure that DHCP had the server reserved. All seems good until I http to the bamboo server. At first I get Page cant be displayed? I look in the address bar and its pointing to the old domain stil. I then (in the URL) type the new domain. The page then renders what looks like a very basc bamboo logon page, I enter my credentils and click next, imediatley see the URL change back to the old domain??? Next steps was to enter the correct server details in the PC local host file, still nothing. I cant foe the life of me see where its picking the old domian from after I ttempt to login to bamboo??? I have no other DHPC or DNS server on the network. ipcong /flush dns etc to no effect.

Can anybody shed any light on what to do/try next. If I can make a backup of the data I would simple run up a new VM of bamboo import the data back.

Cheers

 

Forum: 
Jeremy Davis's picture

Assuming that this is a TurnKey appliance you could try re-running the init (firstboot) scripts and see if that's what's going on. Make sure that you have a good backup first (in the unlikely event that something gets broken) then:

turnkey-init

Alternatively you might be able to search through the Bamboo settings (perhaps there is something there?) or maybe even google might help you find what you're after and guide you how to manually tweak it...

Dom's picture

Hi Jeremy,

Yes, its indeed a turnkey appliance. Yeh, I have goolgled google out I think as not heaps found apart from a reference to a post on here about a similar issue but no data present in the system. It was recommend to run the script again (or similar) if no data present. I have since looked for my last back up in preperation and now hot an bothered that as I cant find them?

Ok, my last resort before running the init script is to perform a back up via SSH/WinSCP as I used the web interface before. I'll have a google on how to do this as I'm green re mysql. Indeed is it actually possible to get a backup of the DB. Rembering I have no web interface for bamboo yet, so ssh my only option.

Using WinSCP/SSH I can connect to it, just not sure where to go to get a backup. 

Thanks

-dom

Dom's picture

Ok, I suppose its a learing curve. Curiosity got the better of me I ran the init script. Went through the initial setup rebooted. And yeh its broken. Now I'll look for the files related to web interface. I have a feeling that unless I use the exact same passwords for i.e. root,mysql,admin etc it may have caused the error below. 

Server Error

404 - File or directory not found.

The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Dom's picture

Ok sorry it was me before with url. Error is as before. I hit the page get a very basic renderd web logon. Login and although address in the url is correct this time its still a page not fond error.

I'll continue to research.

Jeremy Davis's picture

Firstly; even if the website is/was broken then Webmin and phpMyAdmin should both still work (as well as SSH). Unless you adjusted Apache settings, phpMyAdmin (which uses Apache) should still work (the redirect to your old site, is most likely in Bamboo itself). Webmin has it's own server built in and so should work regardless. If it doesn't then your problem is either nothing to do with your server; or things are SERIOUSLY messed up on your server!

Next; TKLBAM is the best way to do backups. To use it the way t was intended you need an AWS account and your appliance needs to have clear access to the internet. Unless you have a ton of stuff on your server the storage prices are really cheap (last time I checked it was ~$0.14/GB/mth - I usually pay about $0.05 cents a month for the backups of 4 different servers (by default it will grow over time, but I don't keep many old backups).

Finally; the init scripts should reset the passwords so in theory it shouldn't matter. Obviously in reality something didn't go quite according to plan.

Probably one of the first things to do is to try restarting Apache and see what happens (e.g. see if you get an error):

service apache2 restart

Copy/paste the output into a new post

To dig a little deeper, have a look at your Apache error log. IIRC it should be:

cat /var/log/apache2/error.log

Chances are that will just repeat the errors you just saw when you tried to restart it, but perhaps there's something else there... Post that too if you want, also double check what 'sites' are enabled:

ls -la /etc/apache2/sites-enabled

It should show a file (actually a symlink) called 'bambooinvoice' which points to /etc/apache2/sites-available/bambooinvoice Assuming that's the case (and there aren't any other sites enabled) then you can compare the contents of that config file against what it should be.

But I just saw you updated and said that you are getting the same error as before... So perhaps scratch most of the above...

If you have now successfully reset the server URL and it is still the same, then I suggest that you clean your browser cache (and cookies) and see if that helps...

To rule out DNS issues you could hardcode the site (temmporarily) into your hosts file.

Dom's picture

Great feed back thanks Jeremy I have learnt a bit about trouble shooting from your post above.

Ok, been very busy the last fews days only now getting back to my issue. The issue is now with loging on to the bamboo interface.

I ended up building a new server (vm) using the Turnkey ISO and it went as planned during installation. I then browsed to the PHPMyadmin site on the server i.e. :12322 succesfully imported my backup into mysql and everything looks fine no errors I can see the data etc.  Now for the daft bit. I can get to logon page which renders fine now, but I cant for the life me login with the email and password I thought I had setup. In other words I cant login to the bamboo system web interface. So my question is how can I go about changing the logon user/password info.

I have access to SSH,  and the PHPMyAdmin page on the server. Using the credetials at install.

Appreciate your help.

-dom

 

Dom's picture

DOH!

I used the forgot password link on the login page. Entered an older email address and presto recived the new password to login. Its all good now.

Thanks again Jeremy

Jeremy Davis's picture

Glad you got it sorted.

Sharon Waters's picture

Hello,

I can no longer email invoices in Bamboo.  PHP error.  Any advice appreciated.

Thanks

 

Jeremy Davis's picture

If so please give more details of your php error. If you are using another version of Linux other than TurnKey Linux then I suggest that you either contact the creator of your Linux Distro or the Bamboo community...

Add new comment