Bryan Ponder's picture

I'm trying to get to Zurmo to load using the IP assigned to the appliance.  When I try to connect I get 


"The server at zurmo can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network."

I'm not sure why its trying to do a DNS lookup when I'm using the IP. How do I get this working?


Thank You!


Jeremy Davis's picture

Many webapps (including Zurmo) require a domain name to be set. So even when you reference it via IP, the first thing that the app does is redirect the IP to the predefined domain name. In your case obviously that domain name doesn't exist (and/or your DNS isn't giving it to you).

So what to do to work around this issue?

Well, it really depends on a number of factors re your individual circumstance:

  • your intentions with Zurmo
    • just testing it
    • putting it into production
  • the environment that you are running it in
    • local VM
    • hosted VPS
  • who is going to be accessing it
    • just you
    • a whole team of people
  • and from where
    • only within a LAN
    • anywhere online

Possibly the quickest, easiest way to get it working just for you (assuming that your Zurmo has a static IP) is to add an entry to the hosts file on your local PC (it's different depending on what OS you are using so google for relevant instructions). If you need to reset the domain name you can rerun the script that sets that:

Bryan Ponder's picture



Thank you for responding.  I guess I still have some learning to do on DNS.  It was my understanding that its sole purpose was to translate a web address to a IP.  


So I don't have control of the DNS server so my planned way of doing it was to hand out the IP to the people that needed it.  This has been the way I've done it for the other Turnkey CRMS that I've tested so far.  I don't have that many users so it wouldn't be a big deal to do without DNS.


Everyone that needs access will be able to hit the mgmt IP that it will be associated with Zurmo

Thanks again for your help



Jeremy Davis's picture

But because of the way that some webapps are written, they require an absolute url (rather than a relative one) to refer to pages internally.

One easy workaround that I forgot to mention (possibly the easiest of them all) when I posted before is to set the IP as the domain name! So just rerun the init script (path bottom of my first post) and just use the desired IP when it asks for it. I have used this with other TurnKey webapps that require a domain name and it's worked, but I haven't tested with Zurmo (I have no reason to think that it won't work though...)

Another way to go would be to use a Dynamic DNS service. AFAIK TurnKey's own HubDNS should even work with a LAN IP (e.g. 192.168.x.x/10.x.x.x/etc). Other DynDNS providers may also allow that too but YMMV...

Bryan Ponder's picture



Thank you for your help.  Setting the IP as the hostname worked like a champ.

Add new comment