Fran Kostella's picture

I got the 64-bit CouchDB AMI running on AWS and was able to use Futon on port 80, as expected. However, I want to use the REST interface typically run on port 5984. The couch config seems to be set to use that port, the port reports to be open, and I created an inbound connection on 5984 in my security group, open to all, but still couldn't connect. 

Any ideas on where this might be tied up? I'm not clear on how this instance is being set up and didn't want to spend time digging into configurations searching for it if this is something trivial. Thanks.


Jeremy Davis's picture

But it sounds like you have checked all the regular sort of places where you would...

On the appliance page (you link to) there is a link to the build code on GitHub which will show you what has been configured and where. The 'plan' is the packages installed (from default repos using package management); the overlay contains files that are overlayed over /; and conf.d contains config script(s) that are run on the appliance to configure it...

If you discover what the problem is (even better if you know how to fix it) then please post back. If you think that it's something that should be enabled by default (as it sounds like it probably should...) then please let us know. We are always happy for advice from people using our appliance on how they could be better! :)

Fran Kostella's picture

Thanks, Jeremy, that revealed the problem.

The server is configured to map the REST API port 5984 to port 80 through nginx, if I am reading this properly. This is to use CouchDB to serve web apps, and not to act as a document database using a json REST API.

I can use curl in a terminal on it as is:

curl ht tp:// 

and it returns the results when using the API on port 5984 of showing all the document headers. Likewise, you can just past the url into a browser and get the data as json text.

The docs claim that it is doing SSL out of the box, but I cannot demonstrate that working.

This configuration is not useful for using the server as a database as you cannot write to it via the API from an app. This might be OK if you are using the Futon web admin interface to modify documents for a web app, but not if you want to set up replicable databases on AWS.

Anyone have any idea on how I can reconfigure this? I want to have a secure docuemtn database not a web page server in a document database. The SSL config here is beyond me and I can't see how to make it do what I want.




Add new comment