Jyotsana Rawat's picture

We are having one issue , one of the member is not able to login in our application.

For this issue, we checked database,  Data is present in data base correctly.
We checked in LDAP with  LDAPSEARCH command: Result No such Object

So we tried to add the record in LDAP with account upload program, which gave error as “Object already exists”.

Then We tried manually insertung the particuar record:

1.We searched with ldapsearch command.
ldapsearch -x -h XX -p XX -D "cn=username,dc=XXX,dc=ABC" -w pwd  -b "uid=uesrid,l=XX,c=XX,ou=XX,dc=XXX,dc=ABC"
Which gave result as “NO SUCH OBJECT”.   -------It is showing no such object.

2.We tried to delete the object with ldapdelete.
ldapdelete -x -D "cn=username,dc=XXX,dc=ABC" -w pwd  -h IP -p PORT "uid=uesrid,l=XX,c=XX,ou=XX,dc=XXX,dc=ABC"
--Results as “NO SUCH OBJECT”

3.We tried to add record in LDAP manually with LDAPADD.
ldapadd -x -D "cn=username,dc=XXX,dc=ABC" -w pwd  -h IP -p PORT  -f XYZ.ldif
---Results in error  “Already Exists”


We searched some blogs over internet, and found that “Sometimes an Object gets deleted Logically  but it presents physically”.
For that restart of LDAP services Can be helpful.

We restarted LDAP services, but still issue not resolved.

Please suggest appropriate solution. Your help will be much appreciated.

Jeremy Davis's picture

I know very little about LDAP so I can't really help you out. My suggestion is try try OpenLDAP community (they probably have a forum or a mailing list). IIRC the version of OpenLDAP included in the TurnKey appliances is from the Debian (Wheezy for v13) default repos.

Add new comment