TurnKey Linux Virtual Appliance Library

TKL LAMP - I broke my phpMyAdmin connection

Hi all,

I think I messed up. I am running LAMP and SPToolkit on an HP Prolient DL380 G5 and everything was working fine until I upgraded Debian from Wheezy to Jessie. In hindsight, this may not have been a good idea. After upgrading, I could no longer get to phpMyAdmin through port 12322. I can get to the Webmin console, SPT, and I can SSH and SFTP successfuly. The only thing that no longer works is phpMyAdmin. I tried updating php through ssh, but it was already up-to-date. I am using a static IP address, if that matters. I am also behind a firewall. No changes were made to the firewall.

This is my first time working with Debian. I have messed around with Ubuntu and Gnome over the last few years, but I am just still a novice. I tried a few things last week and was not successful. Sorry, I can't remember the details. I'm not exactly sure what other info to provide. Let me know what you need and I will get it.

Thanks in advance for your time and advice!

TB

 

Jeremy Davis's picture

It's a Jessie thing...

phpMyAdmin doesn't seem to like sticking to the port you assign it anymore... For the v14.0 (Jessie) release I could log in and make it work but not properly (unless you host it on a directory rather than a port)...

That is part of the reason why we chose to replace it with Adminer...

I'll give Adminer a try

Thanks for the quick reply Jeremy. I'll try Adminer and see if I can make that work. If not, I'll reinstall LAMP

Found a solution

Hi Jeremy,

I just wanted to let you know that I found a solution to my problem, in case someone else asks. All you have to do is remove the port number and replace it with /phpmyadmin. So, either ip.add.re.ss/phpmyadmin instead of ip.add.re.ss:12322 or domain.xxx/phpmyadmin instead of domain.xxx:12322. Found this here: http://sourceforge.net/p/phpmyadmin/bugs/4565/. I did this and it worked instantly.

Troy

Jeremy Davis's picture

Good work...

Glad you worked it out.

FWIW that's what I meant by:

... could log in and make it work but not properly (unless you host it on a directory rather than a port)...

Sorry I wasn't clearer

Guest's picture

Thanks

This worked for me thank you.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)