Dave Enyart's picture

I am not an expert when it comes to linux but am competent enought to follow directions.
I have been trying to update subversion to 1.8.10 and am having a rather difficult time of it.

I am using TKL 13.0 / Debian 7.8 Wheezy - (Revision Control) as a VM on ESXi

The easiest method of using webmin and going to software packages and searching for an update shows that i am at the most current version(subversion 1.6.17dfsg-4+deb7u9)  but the debian packages list 1.8.10 as the most current stable version.

I'm not sure how to update TKL to get this to show up.
I did try to download the .deb package but was unable to complete the install due to missing dependencies, this left my repositories unresponsive and websvn was not pleased with me.

Any suggestions or help would be greatly appreciated.


Jeremy Davis's picture

Probably where you are going a little wrong is that TurnKey v13.0 is no longer (as of about a month & a half ago) running on the latest stable version of Debian. v13.0 is based on Debian Wheezy which is now 'old-stable'.

As a non-Linux regular you may have missed the bit where versions of software are essentially frozen in a particular version of Debian. Security fixes are backported so as to keep the software secure; but otherwise it statys the same as it was the day that version of Debian was released...

Let's not get into the debate of why that's a good thing; but generally on a server it is (IMO anyway...). But there are obviously downsides too. I'm guessing that your need is probably fuelled by a feature in newer versions or the requirements of a 3rd party tool or something similar. Am I right?

Anyway, currently we are working on a v14.0 release which will be built on Debian Jessie (latest/current stable). So seeing as you are self hosting perhaps you'd be interested in helping us test it out!? I posted a blog post last week which will give you the low down. If you are interested in helping out and need further guidance please ask.

If that's not a direction you'd like to take then you have a couple of other options. I'll give you a basic rundown and if need be I'm more than happy to give extra detail...

  • Upgrade your existing v13.0 to Jessie - should work but may be some issues and once you start there is no going back...
  • Make your server a chimera i.e. pin packages from Jessie in a Wheezy install. This is a totally legitimate way to do things but not something that I would generally advise for Linux newbs. It can be tricky to set up right unless you understand what you are doing. If you're not careful you might end up with a half Wheezy, half Jessie mess...
  • Install from 'backports'. IMO seeing as this option is available it is perhaps the best option of them all... As you pointed out; latest stable (in Jessie) is 1.8.10 but as you discovered the version in Wheezy is 1.6.17. However; there is a separate "official" Debian repo called backports, where newer versions of software get backported...). And Wheezy backports just so happens to have 1.8.10! :)

    Read more about Debian backports here.

Dave Enyart's picture

Thanks for the help!

Right now we are not looking into doing an upgrade, and this is also a production server for our internal webserver and the subversion repository.

I keep getting my butt kicked at this point.
I have added

deb http://http.debian.net/debian jessie-backports main

to my /etc/apt/sources.d/sources.list

When I try to run

apt-get -t jessie-backports install subversion

I get 

apt-get -t jessie-backports install subversion 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
subversion is already the newest version. 
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Any additional help you can provide would be appreciated.

Jeremy Davis's picture

You need to run 'apt-get update' to update the local list of available packages. Until you do that your system can't see the packages available from backports...

If that still doesn't work, try "apt-cache policy subversion" and copy paste the output.

Dave Enyart's picture

Here is the output as requested

apt-cache policy subversion
Installed: 1.6.17dfsg-4+deb7u9
Candidate: 1.6.17dfsg-4+deb7u9
 Version table:
*** 1.6.17dfsg-4+deb7u9 0
500 http://security.debian.org/ wheezy/updates/main amd64 Packages
100 /var/lib/dpkg/status
1.6.17dfsg-4+deb7u8 0
500 http://cdn.debian.net/debian/ wheezy/main amd64 Packages

Thank you

Dave Enyart's picture

Sorry for the problem, It was my mistake.

I was trying to use jessie-backports as my new source in sources.list
It should have been wheezy-backports (https://packages.debian.org/wheezy-backports/subversion)

Then I was able to run apt-get update

apt-get update

Then once the package lists were updated I had to run 

apt-get -t wheezy-backports install subversion

Thank you for pointing me in the right direction. Next time I will try to follow them better.

Jeremy Davis's picture

I actually only just noticed that you said that you tried to install from Jessie backports... I probably should have picked that up and asked about it... I blame the fact that I'm working on the v14.0 (Jessie based) release ATM! :)

Anyway, you got there in the end and all is well! :)

Add new comment