Herin's picture

I'm having a site with the below url:


and I created tklapp.com instance with following url:


- It was working fine till yesterday morning, but sudden of it stopped working. Moreover, my site is also got messed up. I did not even touch any of them. I don't know how this happened.

Please advice me asap what I should do to get my tklapp.com site and my website back to working mode as it's the live site and many people are using it.

Please lists the necessary steps I need to perform.

Thanks for the help in advance.

Jeremy Davis's picture

We'll need lots more info about your servers to be able to help.

I'm assuming that they are on two separate TurnKey servers? What appliances are they? LAMP? WordPress? Something else? Are you controlling them from the Hub?

Have you checked the logs from your servers? That's probably a good place to start. They are all in /var/log. If it is a LAMP based appliance then I'd have a look at the end of both the apache error log and the mysql log too. This (or something close) will do the trick:

tail -20 /var/log/apache2/error.log
tail -20 /var/log/mysql.err

Do you have backups enabled? If so then perhaps you could restore to an earlier state?

Even though TurnKey lowers the bar and makes managing Linux servers easier; they are still self-managed servers. Unless you want to pay someone to manage your servers for you, you need to develop at least a basic Linux knowledge (or at least have interest in gaining it).

Herin's picture

I know about it. But I'm not able to get the login page of turnkey linux lampstack.

where I can add username and password.

The url of it was:


But it's not showing the login page.

And I have the knowledge over linux system and even I tried to get my last backup restored on linux system by going through the below steps like,

apt-get update

apt-get install tklbam

but when I tried this, it constantly showing an error like does not locate the package

I tried all my ways, can you please restore my last backup which was taken 2 weeks ago?

I can provide you the credentials.

I'm using amazon server to host my website.

Thank you and waiting for your next answer.

Jeremy Davis's picture

And then restore your backup to that. If your current server is v13.0 then you can launch a server that will restore your backup on the fly; otherwise you'll need to manually restore to the new server. You don't need to worry about installing TKLBAM or anything then... Once you have it all fixed then you can destroy the old one (once you are sure you don't need it any more).

What login do you mean? The LAMP appliance doesn't have a log in page by default. Or do you mean Webmin? In which case it seems to be working for me: https://myserviceteam.tklapp.com:12321/

Herin's picture

How can I allocate a new IP address and then associate it and then change the DNS records?
as the server is ok - it looks like all the files are still there, but I lost the IP.

Jeremy Davis's picture

You will find the HubDNS docs in the documentation section here.

Hopefully that should help sort you out.

Out of curiosity why did your servers "lost the IP"? It wouldn't have just occurred on it's own. Did you (or someone/something) restart the servers? Have their IP adresses changed? If you didn't do it (accidentally or on purpose) then someone or something has! Personally I'd be quite concerned about working out who (or what) made the changes...

Also keep in mind that it will take about 5-10 mins for the changes to be replicated across the internet. Some crappy DNS providers (e.g. cheapskate ISPs) can take days...

Add new comment