Hugh's picture

Hi all,

I created a server using the Hub 5 hours ago and associated it with a domain name that I registered through Route 53 (hostname www).  DNS lookups still arent finding the right host.  Am I doing something wrong?

Any advice much appreciated.

Best wishes


Jeremy Davis's picture

It should take no more than 5-10 minutes for the DNS to propagate once it is set.

However I have had massive issues in the past with the DNS that my ISP provides. They have caching settings that override those provided by TurnKey. The result of that is that it sometimes takes days for an existing DNS entry to get updated with the new info.

Sometimes also the DNS provided by consumer grade router/modems can be a bit flaky. If you are using something like that as a DNS forwarder then it may be worth adjusting your config. If you are using Windows then that too will cache DNS info (although usually not for too long).

I have found that if I use google public DNS ( & then it updates much faster. It is basically instant for new (previously unused) domain names and 5-10 (15 max) for updated domain names.

If you want please feel free to post the domain name and I'll see if it works for me.

Also it may be useful for you to get an "elastic IP". It is essentially a static IP that you then "attach" to a server. Elastic IPs are free for running servers; but you pay a small fee for every hour that your server isn't running (or the elastic IP isn't attached to a running server). If you plan to have an "always on" site then that wouldn't matter... Technically it should be possible to get one and attach it wihtin the Hub; but recent changes made by Amazon mean that in some regions it doesn't work anymore. If your one of those unlucky ones; you'll need to use the AWS management console to create and attach your elastic IP...

Hugh's picture

Thanks Jeremy.  Set DNS servers to and and will await developments. 

The server should be at, if you have time to check it would be very grateful.

Hugh's picture

The problem was that, despite registering the domains through Route 53, the NS was set to Gandi, not Route 53.  Thanks Amazon.

Thanks for your help, Jeremy.

Jeremy Davis's picture

But it seems like that FQDN is not currently resolving... :(
Hugh's picture

It's resolving OK for me (, also.  What DNS server are you using Jeremy?

I was actually going to ask how to make sure <domain> shows each site (as a synonym for www.<domain>).  Hope that makes sense - separate thread needed perhaps.

Hugh's picture

Oh!  Should have thought, I have the security group set so all the services are accessible only from my IP.  Not sure if that would stop it resolving for you but if so, sorry to give you the run around.

Jeremy Davis's picture

No problem at all. I'm using a local (BIND9) DNS which forwards requests to google (

The IP DNS returns for is but I can not connect to anything on that IP. resolves to but nothing on that one either. So I'm guessing your settings stop any resolution (beyond DNS finding the IP) on my end! :)

Don't forget to adjust your AWS security settings when you're ready to go live though! :)

Hugh's picture

OK sounds like it's all working, thanks again Jeremy.

Add new comment