PeteK's picture

Hi.  I've just installed the latest mediaWiki vm, which is running under VMWare Player.  I've been through the initial steps that setup passwords etc and am faced with the MediaWiki Appliance Services menu within the Turnkey Linux Configuration Console.  I'd like to do something more !  I presume that I should just be able to copy each of the URLs into my browser and start doing stuff - is that right ?  I've tried this, but although I can ping the IP address, my browser (IE v 11) won't connect.  Any suggestions would be very welcome.

I'm a complete novice with mediawiki and hardly any better with linux.


Pete K


Jeremy Davis's picture

TBH I'm not sure why you can ping but not see it in the browser. What virtual newtwork setting are you using? I would recommend using "bridged". NAT (which is often the default) will generally cause you issues on a server OS.

THe only other thing that jumps to mind is the possibility of an IP conflict. To test that you could pick an IP (on the same subnet as your network) that you guess should be free. Then ping it. If you get no response then manually change your appliance IP to that. Then try again...

PeteK's picture

Thanks for confirming that things should work as I expected.  Now that I'm more confident that it is a connection issue I can explore it further - starting with your suggestions, which are much appreciated.

PeteK's picture


I checked my VM adapter settings and the NW was indeed set to bridged.  That still didn't work, so I changed it to "Host Only - a private network shared only with the host" and that worked a treat.  OK, its not what I will need eventually, but its perfect for now.  Thanks again for your help.


Jeremy Davis's picture

But TBH I'm not sure why Bridged wasn't working. It should. But seeing as Host only works then the issue is most likely in your OS, you network or in your Virtualisation software...

Add new comment