sidboy55555's picture

hi, when I reinstalled webmin the default port is 10000, but I changed it to 12321 in the /etc/webmin/miniserv.conf config, but when i try to restart webmin it says:

Job for webmin.service failed. See 'systemctl status webmin.service' and 'journalctl -xn' for details.

 

http://pastebin.com/NQuh6MRk

http://pastebin.com/vtXtdrzs

Forum: 
Jeremy Davis's picture

If so; yes it should be set to 10000. In v14.0 we put it behind stunnel. So stunnel listens on port 12321 and forwards to port 10000 internally. Webmin should not be publicly available on port 10000 though!
sidboy55555's picture

yes I use v14.0 r2.

but I still don't know what to do...

Jeremy Davis's picture

Please post your Webmin miniserv.conf. To do that:
cat /etc/webmin/miniserv.conf
sidboy55555's picture


port=12321
addtype_cgi=internal/cgi
realm=Webmin Server
logfile=/var/webmin/miniserv.log
errorlog=/var/webmin/miniserv.error
pidfile=/var/webmin/miniserv.pid
logtime=168
ppath=
ssl=1
no_ssl2=1
no_ssl3=1
env_WEBMIN_CONFIG=/etc/webmin
env_WEBMIN_VAR=/var/webmin
atboot=0
logout=/etc/webmin/logout-flag
listen=10000
denyfile=\.pl$
log=1
blockhost_failures=5
blockhost_time=60
syslog=1
session=1
premodules=WebminCore
userfile=/etc/webmin/miniserv.users
keyfile=/etc/webmin/miniserv.pem
passwd_file=/etc/shadow
passwd_uindex=0
passwd_pindex=1
passwd_cindex=2
passwd_mindex=4
passwd_mode=0
passdelay=1
cipher_list_def=1
sudo=1
root=/usr/share/webmin-1.770
mimetypes=/usr/share/webmin-1.770/mime.types
server=MiniServ/1.770
preroot=bootstrap
logouttimes

 

Jeremy Davis's picture

Change the entries in your conf (that you currently have) to these:
port=10000
ssl=
And add these new ones (at the bottom is fine):
inetd_ssl=1
preroot=theme-stressfree
bind=127.0.0.1
sockets=
no_resolv_myname=0
ipv6=0
Peter's picture

I did the same and I still can not get into webmin. Any progress?

Thank you

Jeremy Davis's picture

See if it's running:
service webmin status
If it's not, start it:
service webmin start
Peter's picture

It is started and running. This is a new installation aout ot the box.

Jeremy Davis's picture

I can not reproduce your issue. I just did a clean install of Core and it works fine for me. As all of our appliances are built from Core and all use the same Webmin packages (from our repo) I suspect that there is something on your end causing the issue.

So can you please provide some additional info. I.e. which appliance in particular? Which version? I assume v14.1 but to be 100% sure. If you don't know or want to check , run this:

turnkey-version

Also what is the exact error message you are getting in your browser when you try to connect?

Add new comment