Hugo Hernan Buitrago's picture

I have HyperV so the ova machines don't work , or i haven't got them to work.  I installed th Observiumfrom iso, and it discovers and polls fine, the problem is that it don't shows the graphs.  If I took  a graph url and add &debug=1 to the end i get to see all the steps to generate the graph with the following warnings

 

Warning: fclose(): 17 is not a valid stream resource in /opt/observium/includes/rrdtool.inc.php on line 75
 

 

Strict Standards: Only variables should be passed by reference in /opt/observium/includes/common.inc.php on line 624

Strict Standards: Only variables should be passed by reference in /opt/observium/includes/common.inc.php on line 625

Strict Standards: Only variables should be passed by reference in /opt/observium/includes/common.inc.php on line 626

Strict Standards: Only variables should be passed by reference in /opt/observium/includes/common.inc.php on line 624

Strict Standards: Only variables should be passed by reference in /opt/observium/includes/common.inc.php on line 625

Strict Standards: Only variables should be passed by reference in /opt/observium/includes/common.inc.php on line 626
 

And to the end there is the image i am looking for, correctly rendered.   So maybe these warnings are send as part of the image and the browser finds it corrupted and dont show it.

I revised and php has dissabled the strict warnings, so they maybe because of the debug thry appear?

How can i get my grapds to show?

Forum: 
Tags: 
Jeremy Davis's picture

I had a quick google and couldn't find anything that seemed quite like the issue that you are having.

If you've turned the php error level up, then my guess is that's the cause, but I can't be sure. Perhaps try turning it back down again...

You could try updating to the latest release and see if the issues still persist. Although obviously make sure that you have a backup before you do. Instructions are here.

If you continue to have issues after upgrading then I suggest that you ask on the Observium mailing list.

Regardless I'd love to hear how you go.

Hugo Hernan Buitrago Rios's picture

I tried to ask in the Issue tracking and it was immediately closed because the tkl version was too old, but as I had the september 2015 TKL machine I verified and the observium was the latest community edition release from June 2015; maybe soon they will put out a new one but without paying for an upgrade i can't access it now.

 

I have not modified the error reporting configuration, even i verified that it is

error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

that should take care from these messages

 

I already am on the latest Community edition available to yesterday, so updating is not an avenue open to me.

 

I will try again on the mailing list, thanks

Jeremy Davis's picture

I thought that you said that you had changed the logging level. Sorry about that.

Also I just remembered that there are some bugs in the v14.0 Observium appliance that will be fixed for the v14.1 release (except for the one labelled "won't fix"). TBH I don't think that they would cause the issue that you are having but you could try performing the workarounds (as provided in the bug reports).

At least with logs you may be able to better troubleshoot the issue as perhaps it is a problem with our install (i.e. maybe you've found another bug).

Something that may be relevant is the Apache config. Their Apache 2.4 config is noted on their install page (about halfway down). Our config is slightly different to theirs and mostly that wouldn't be an issue. However I have noticed that they recommend "Options Indexes FollowSymLinks MultiViews" whereas we are currently only providing "Options +FollowSymLinks". Try changing that (and only that) line in your /etc/apache2/sites-avaialble/observium.conf (removing the "+" and adding "Indexes MultiViews"). Then restart Apache ('service apache2 restart') and see if the errors are gone.

One other thing that is mentioned (and may be relevant) is that on their install page; it suggests that you turn down the default PHP error reporting level. See the bottom of this page. Note though that the suggestion there is to edit /etc/php5/cli/php.ini (for php commandline usage) whereas to change the Apache (webserver) error reporting you need to adjust /etc/php5/apache2/php.ini. The current default is "E_ALL & ~E_DEPRECATED & ~E_STRICT"; so you could try turning that down to "E_ALL & ~E_NOTICE" and see if that helps.

I suggest that you do both of the bugfixes (as noted on our issue tracker) first. Then restart Apache and see if the errors are gone. If they still remain; then try adjusting the Observium Apache site (and restart Apache again). If they still remain, try adjusting the php error level (and restart Apache again).

Let me know if you have any joy, and please note which (if any) resolved it. If we can confirm a fix/workaround then we'll add that to the v14.1 release too! In the meantime, I will try to reproduce your issue when I get a chance...

Regardless thanks for taking the time to report this and trying to follow up with upstream. TBH I'm a little surprised (and disappointed) that they were so quick to close the issue without trying to understand your environment a little more (just assuming that you were using an old version of TurnKey and that you hadn't updated the software yourself). Anyway...

Add new comment