Alex Reil's picture

Hi all,

i have problems accessing the processmaker portal site after installing turnkey processmaker.

After installing the system every attempt to reach http://192.168.50.3 or https://192.168.50.3 via internet explorer gives an error "This page can't be displayed".

Trying wget gives an error, too:

root@processmaker ~/spielwiese# wget 192.168.50.3:80
converted 'http://192.168.50.3:80' (ANSI_X3.4-1968) -> 'http://192.168.50.3:80' (UTF-8)
--2015-12-30 13:20:06--  http://192.168.50.3/
Connecting to 192.168.50.3:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: unspecified
ERROR: Redirection (302) without location.

Webmin and adminer do work ...

I checked the listening ports:

root@processmaker ~/spielwiese# netstat -tulp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost:12319         *:*                     LISTEN      583/shellinaboxd
tcp        0      0 *:12320                 *:*                     LISTEN      596/stunnel4
tcp        0      0 *:12321                 *:*                     LISTEN      596/stunnel4
tcp        0      0 localhost:mysql         *:*                     LISTEN      1152/mysqld
tcp        0      0 localhost:webmin        *:*                     LISTEN      1195/perl
tcp        0      0 *:ssh                   *:*                     LISTEN      482/sshd
tcp        0      0 localhost:smtp          *:*                     LISTEN      1353/master
tcp6       0      0 [::]:https              [::]:*                  LISTEN      2139/apache2
tcp6       0      0 [::]:12322              [::]:*                  LISTEN      2139/apache2
tcp6       0      0 [::]:http               [::]:*                  LISTEN      2139/apache2
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      482/sshd
udp        0      0 *:10000                 *:*                                 1195/perl

It seems, that apache only listens on ipv6 adresses. So i checked /etc/apache2/ports.conf:

root@processmaker /etc/apache2# cat ports.conf
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80

<IfModule ssl_module>
        Listen 443
</IfModule>

<IfModule mod_gnutls.c>
        Listen 443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Listen 12322

So apache should listening on all interfaces, right?

Firewall is not activated, and the http-request is seen by apache, no error.log entry:

root@processmaker log/apache2# tail -f other_vhosts_access.log
localhost:80 192.168.50.185 - - [30/Dec/2015:13:33:02 +0000] "GET / HTTP/1.1" 302 389 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)"

 

So, i am stuck here ... here is the conf file for apache regarding processmaker:

root@processmaker log/apache2# cat /etc/apache2/sites-enabled/processmaker.conf
ServerName localhost

<VirtualHost *:80>
    UseCanonicalName Off
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/processmaker/workflow/public_html
</VirtualHost>

<VirtualHost *:443>
    SSLEngine on
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/processmaker/workflow/public_html
</VirtualHost>

<Directory /var/www/processmaker/workflow/public_html>
    AddDefaultCharset UTF-8
    Options +FollowSymLinks
    AllowOverride All
Require all granted

    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ /app.php [QSA,L]

    AddOutputFilterByType DEFLATE text/html
</Directory>

Sorry for the long posting, but i think this might be interisting stuff for the professionals out there ...

Looking forward to read about hints, suggestions, etc.

 

Thanks in advance

 

Alexander Reil

 

Forum: 
Jeremy Davis's picture

I just did a test install of ProcessMaker and it all works OOTB for me.

TBH 192.168.50.3 seems like a weird IP. Is your LAN using the 192.168.30 address range? If not perhaps having it on a different subnet is the issue? The most common LAN subnet IP ranges are 192.168.1.x & 192.168.0.x.

Alex Reil's picture

Hi Jeremy,

thanks for your hint. The IP is correct. I can ssh with the turnkey server, also webmin and adminer do work...

 

Alex

Alex Reil's picture

Hi all,

i was expecting to reach the processmaker start page simply with http[s]://192.168.50.3

This didn't work, but explicitly typing http[s]://192.168.50.3/index.html works...

 

Alex

 

Jeremy Davis's picture

I wonder if this might be a Internet Explorer glitch? Out of interest, what version are you using?

I only use Linux so I am unable to check IE, but http[s]://192.168.1.107 (in my case i.e. no explicit inclusion of index.html) works fine in both Firefox and Chrome?!

FWIW it actually auto redirects me to http[s]://192.168.1.107/sys/en/neoclassic/login/login Out of interest I also tried http[s]://192.168.1.107/index.html and that redirects to the same url.

Looking at the Apache config I don't see anything that should cause any issues. Considering that this appliance is doing an auto redirect (that we didn't explicitly configure in the Apache config) my guess is that for some reason Internet Explorer doesn't understand the built in ProcessMaker redirect. Although I'm not sure why explicitly point it to the wrong place (i.e. index.html) makes it work!? I'd be interested to see how it behaves with another web browser on your system (as perhaps it's something else on your system that is interfering; e.g. some browser security setting or plugin)?

However on a completely separate note; I don't seem to be able to log in with the password that I created. Are you having any issues with that?

[update] Oops, it was just because I wasn't specifying the workspace. FWIW the default workspace is "workflow"...

Alex Reil's picture

Hi Jeremy,

i use IE 11, fully patched.

It seems, that processmaker doesn't work very well in our environment. We use a lot of other web based software from different sources, all work very well.

I will test other bpm software, because time is short ... at home i have a Linux environment and if there is time left, i will address this issue then, but for the moment processmaker is paused.

Thanks for your patience and answers...

 

With kind regards

 

Alex

Jeremy Davis's picture

I did find someone else who is experiencing the same issue (see here) but there appears to be no response from anyone else regarding it. Browsing their docs it appears that it should support IE11. So perhaps there is some configuration that we have that is sub-optimal? Perhaps there is some glitch in your IE config somewhere although I have no idea what might cause IE to ignore redirects...

Add new comment