Bryan's picture

I have been running a mediawiki virtual machine for several years, largely without issue. Recently though it has started becomming non-responsive. By non-responsive I mean that:

  1. Access to the wiki via its web address ceases
  2. Access to the wikis browser-accessed shell & webadmin ceases
  3. Even the window of the VM (in the host machine) stops responding - i.e. it won't shut down if I "send the shtdown signal" after clicking the 'x' on the machines window in the host.

I'm confident this isn't an issue with the host, as it is running 3 other turnkey virtual machines without issue. The last time I had an issue with this machine it was due to hard drive space; but less than 15% is currently in-use and running the solution to my last issue didn't help.

Oddly, after reforcing a reboot it'll run fine for 12-18 hours, and then become non-responsive again. 

Anyone know how to fix this issue?




Jeremy Davis's picture

When you say "Even the window of the VM (in the host machine) stops responding" does that mean that you can longer type within the VM terminal in the window either? I.e. is the machine totally locked up aka frozen?

TBH I haven't come across that before. Are the other TurnKey VMs the same version?

Have you checked the syslog on the server to see if there is anything strange logged around the time it becomes unresponsive? If you can still run commands within the VM terminal after this happens then it is highly likely the log will show what the error is (or at least give solid hints). If it's totally frozen then it is possible that there is nothing of interest there.

Also rebooting the host (assuming that it is running continuously) and running a fsck (or equivalent disk check) on both the host and the VM might be useful steps (and might help eliminate possible causes if nothing else).

TBH it does sound suspiciously "hardware" related (in my experience freezes are almost always hardware related). Perhaps a bad stick of RAM on the host? Or some hard drive corruption (both of those things can happen without having negative impacts on on other VMs; although RAM is unlikely if your host is Windows).

It is really strange that it takes so long for it to happen.

You could also consider upgrading to a newer version of TurnKey and cross your fingers...

Bryan's picture

I upgraded to a new version; 22 hours without failiure so far.

Jeremy Davis's picture

Although TBH personally I like to find the cause of issues if possible. Then I can have piece of mind that I've really fixed it. :)

FWIW this still doesn't rule out the possibility of something amiss hardware wise on the host (corrupt harddrive or flaky RAM). If your host OS is Windows then the chance of RAM issues seems unlikely to me. In my experience Windows is much more sensitive to RAM issues as it will usually crash (BSOD) if there are RAM problems.

It is quite possible that the issue was caused by some minor corruption of the virtual hard disk that your old VM was using - which may or may not be related to a corresponding physical hard drive issue (i.e. the physical hard drive may be fine, or it may have been the cause).

Bryan's picture

My host in ubuntu, so its not likely a windows RAM issue. Perhaps it was corrupted, although a disk check of the host system didn't turn up anything. Regardless, I'm not pushing 48 hours without issue, so it looks like the problem may be solved.



Add new comment