CSS's picture

I found that Samba Group Sync do not work.

How can I fix it.

Plz advise, Thank you!

Jeremy Davis's picture

I really need to know a little more about your server; e.g.:
  • what version of TKL it is (if you're not sure run 'turnkey-version')
  • what appliance you're using
  • how you're running this (i.e. commandline or Webmin or something else)
  • exactly what result your getting (inc specific error messages)
  • anything else that you think may be relevant...
  • CSS's picture

    Thank you

    My TKL is version 14 and I am using a EXSi VMware Virtual Machine.

    I run it with Webmin (ver. 1.760). 

    I had tried to add the Samba Group with Group name as A , Group type as Domain group , but failed with Error Message :

    Failed to save group :

    adding entry for group A failed!

    Besides, I found no log message refer to the error message.

    Please help to fix it. Thank you.



    CSS's picture

    There is the other Question.

    Are there any way that I can add subfolder access right by group (Any group type) in Window 7 joined Turnkey Domain?

    Please advise if there is any way to get it done.

    Thank you.


    Jeremy Davis's picture

    There is significant difference between them. They both use the same version of Samba (v4.1 IIRC) but there are differences in config. The Domain Controller appliance uses the new Samba4 (AD compatible) config. Whereas the Fileserver uses the legacy (Samba3/NT4) style config. The newer config style does not require matching Linux groups and users for Samba/Windows groups and users.

    For configuring users and groups in the Domain Controller you can use the commandline samba-tool (see Samba docs here). You should also be able to use the Windows native tools to configure all your users and permissions on the Samba AD DC. Webmin should also work although TBH I don't recall the exact process.

    Add new comment