phobos's picture

I already have a turnkey owncloud,samba, etc server running on a raspberry pi 2. it has been running great for over a year now. I decided to make a media server for my father in law using an old HP G62 laptop. I have successfully installed the system and received the standard turnkey confconsole menu. However, when I try to access any service to begin setting things up, all connections are refused. I have already pinged the server from multiple computers and all are succesful. I havent refused any certificates and I have already tried using http and https but nothing works. Am I missing something here?  I have also tried multiple web browsers. Also, I have updated everything with apt-get. Is there a built in firewall im not turning off or a configuration file that allows connections? Also this is all local behind the router. Im not trying to forward traffic externally. Also, this in not in VM but installed on HD.


PS: I can login with putty. Nothing else works.

Jeremy Davis's picture

Firstly how did you install? From an ISO? If so what version?

TurnKey does include a Firewall (IPTables) but it is disabled by default, so unless you've turned it on, I highly doubt that is the issue.

If you have successfully updated software with apt then it's obviously getting a network connection. I'd also double check pinging other computers etc from within your TurnKey server to make sure there is not some internal network strangeness going on.

Your first screenshot shows "connection refused" which suggests that it is contacting your server but your server is saying "no"! So there should be some note of that somewhere in the logs (hopefully). If you can find that it may shed some light on the situation? Logs should (generally) be in /var/log.

I'd also double check that the relevant services are running; e.g. webmin, shellinabox, apache2(?), etc. Use the 'service' command with the 'status' operation. I.e.:

service webmin status

Also in v14.x both Webmin and Webshell (shellinabox) are hidden behind stunnel so you should check that is running too (I don't recall OTTOMH whether it's called 'stunnel' or 'stunnel4'.

Another thing that I have come across a number of times is an IP conflict. I.e. sometimes 2 machines have the same IP. This would explain why some stuff works (ssh) but other stuff doesn't (pretty much everything else). The easiest way to check that is stop your server and ping the IP. If you get a response then that's your issue, otherwise you should be ok (it's not foolproof but should be a fairly reliable test).

kinjo's picture

Add new comment