Chris Musty's picture

OK So here is the scenario.

Bunch of vm's running on a server under proxmox.

Firewall kicks the bucket so I decide to swap it out for clearos (not too bad).

Ever since then I get the error message above, here it is again

S3DataError: BotoClientError: ETag from S3 did not match computed MD5

Firstly WTF

Secondly I tried to force a tklbam-init over to another hub account and it also fails.

Any ideas? Google is not being helpful!

Jeremy Davis's picture

Haven't seen you around for ages! Hope life has been treating you well.

TBH I haven't come across that one before. I assume that is part of the Python error trace when you try to run a backup?

When you say "I tried to force a tklbam-init over to another hub account and it also fails" is that giving the same error at the same place?

Perhaps if you could post the full stack trace and clarify which version of TurnKey I'll pass it on to Liraz and see if he knows what is going on.

Chris Musty's picture

Jeremy, it has been a while but I certainly have been lurking in the background.

Its the same old story, busy busy busy.

Great thing is I have been heavily involved in setting up TKL within small businesses with some great outcomes.

I would dearly love to contribute again and am working towards that goal.

So to the issue at hand...

I need to get some more detail and fire it back to this thread.

I get the same error between my wifes and my own hub account but I really have not done any troubleshooting. I am almost convinced I have done something mindless but as mentioned I did swap out my old pfsense firewall for clearos and thats when the issue arose.

It complains the hash is wrong but I am not sure where or how it generates this.

Will update later, right now I am all linuxed out...

Chris Musty


Specialised Technologies

Jeremy Davis's picture

I hear you! I've been crazy busy myself...

Glad to hear that you've been spreading the TurnKey love! :)

Look forward to hearing more from you when you get a chance.

OTTOMH only thing I'm wondering, is there some sort of proxy as part of your new config/firewall? Maybe that is mangling the traffic somehow and upsetting AWS?

Anyway, when you get a chance and do some more troubleshooting post back and let us know how it goes. If you need further input and don't want ot post stuff publicly shoot me an email if you want (jeremy AT

Chris Musty's picture

I have to hang my head in shame... what a newbie problem I completely missed.

Yes I had a proxy server setup. It was one of the "out of the box" type configs so I really didn't pay any attention to it. The moment it was disabled - pure tklbam bliss...


Thanks Jeremy

Chris Musty


Specialised Technologies

Jeremy Davis's picture

Glad you got it sorted and thanks for posting back to confirm.

Add new comment