steve.iannuzzo's picture

I just installed File Server in my Virtualbox, sftp (port 22) is working just fine.

When I try to use SambaDav going to https://172.16.1.249 it drops me to //, when I try to create a folder or upload a file I get this error.

-----------------------------

This XML file does not appear to have any style information associated with it. The document tree is shown below.    

<d:error><s:sabredav-version>3.0.9</s:sabredav-version><s:exception>Sabre\DAV\Exception\Forbidden</s:exception><s:message>Forbidden: Cannot create shares in root</s:message></d:error>

------------------------------

I am logging in with a Samba user, tried diffenrt browswers, and have restarted Samba services. Still get error.

Any help will be much appriciated!!!!

 

 

Forum: 
Jeremy Davis's picture

I wonder what is going on there? I wonder if it's something to do with the recent Samba security updates that came out just after we released the v14.1 appliance?

IIRC it introduced a regression which made root shares (i.e. /) problematic. Maybe that's why you're getting the //? That would seem to align with the erro you get (although not sure about the xml stuff).

I just had a quick google and couldn't find anything of any value though but I'm sure that it has been discussed here on the forums...

Have you also tried with the root user?

I'm flat out at the moment, but when I get a chance I'll have a look and see if I can work out what is going on, or at least reproduce your issue.

So I don't forget I've put an issue on our bug tracker: https://github.com/turnkeylinux/tracker/issues/627

tekbit's picture

I might have figured this question out. Try installing 'smbclient'. This should get it resolved.

The SambaDAV relies on the 'smbclient -L' function to discover the available shared directories. Check for reference: /var/www/sambadav/config/config.inc.php and look for 'smbclient_path'. However, the 'fileserver v14.4' appliance does not come with it pre-installed. 

Jeremy Davis's picture

It was definitely working fine back when we launched v14.0 but perhaps that change was introduced with the (security) update to Samba4.2?

Thanks for posting

tekbit's picture

Hey Jeremy,

This might be indeed the case. I'm not fully sure myself. I just know after installing 'smbclient' it started working like a charm :)

 

-- tekbit

Jeremy Davis's picture

TBH I'm not 100% sure why it is doing it, but it appears that the Samba auto security update is uninstalling smbclient. Once you manually reinstall it the whole system works again (and doesn't uninstall smbclient again).

We probably need to dig a bit deeper to try to work out exactly what is going on. But thanks again for posting.

David Richards's picture

+1 on this.  I have been absolutely clueless for the longest time why this has been doing this... my servers would start out with SambaDAV access but would then stop suddenly without reason. Installing smbclient is the fix.

Add new comment