Colby Westerfield's picture

After doing an upgrade and rebooting my box, openvpn no longer works. I have rebooted a few times, same error everytime. The machine is using turnkey core jessie.

Openvpn error

Fri Sep 23 10:17:47 2016 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
Fri Sep 23 10:17:47 2016 Exiting due to fatal error

Kernel

# uname -r
3.16.0-4-amd64

dmesg output:

[221169.883496] tun: Unknown symbol __sk_detach_filter (err 0)

 

 

 

Forum: 
Jeremy Davis's picture

Apologies on slow response. We've been crazy busy behind the scenes and we've been doing a billing migration with a ton of legacy Hub users which has added significantly to the support load...

From what you state, this is a TurnKey Core appliance which you have installed OpenVPN on?! Out of interest, is there a reason why you didn't just use our OpenVPN appliance?

And can you please describe what you mean when you says that you "upgraded" OpenVPN? Did you just upgrade the OpenVPN software or the whole system? Did you just do an update (for OpenVPN or the whole system) from the Debian repos via apt? Or some 3rd party source and/or some other method?

Bottom line is that it looks like something within your configuration is not compatible with this newer version you have upgraded to. But it may be a dependency issue or something completely separate.

If you give us some more info, perhaps I may be able to assist. Even if you've already fixed it yourself, posting some more info (including your fix) would be super awesome as then others could also benefit! :)

Jacob Lopes's picture

Fresh run of the container referenced above as the "OpenVPN appliance". Its unclear if it works before updating.

error message 

Tue Oct  4 05:29:40 2016 us=705655 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)
Tue Oct  4 05:29:40 2016 us=705669 Exiting due to fatal error

 

I can get it to run if do the following commands 

# mkdir /dev/net
# mknod /dev/net/tun c 10 200
# chmod 666 /dev/net/tun

then run

openvpn --cd /etc/openvpn --config /etc/openvpn/server.conf

 

It works until i reboot the container.

Running on:

"Proxmox Virtual Environment 4.2-2/725d76f0" 

"debian-8-turnkey-openvpn_14.1-1_amd64"

 

Colby Westerfield's picture

Sorry guys, I deleted the VM and started over. The new VM works fine. 

I was not using a conatainer, because I knew about some of the limitations that present with doing so. 

I was just using jessie core and then used apt to install openvpn. I though the openvpn appliance was for an openvpn server, and all I need is a client.

I had used the openvpn client for about 6 months without issue. Then I did an apt-get update and upgrade and when i rebooted, no google search I could find would make the tun/tap message go away.

I thought maybe my openvpn configuration was the problem, so I spun up a new VM, installed openvpn and tried it and it worked. Flummoxed, I just rsynced my data over and deleted the faulty original. 

All is better now.

Jeremy Davis's picture

It certainly does sound strange...! Glad you managed to work around it ok though.

Add new comment