Eric's picture

I have installed the latest  PostgreSQL - Advanced Object-relational Database System.  From the console I can set the DHCP or Static IP address.  I can then ping and access the appliance.  After reboot I can no longer ping or access the appliance.  After resetting the DHCP or Static IP address at the console, I can again access the appliance.

After searching the intenet I tried the solution here

I tried to do the config in /etc/dhcpcd.conf: (dhcpcd.conf did not exist so I created it):

interface eth0
static ip_address=
static routers=
static domain_name_servers=

This did not work for me.

/etc/network/interfaces looks like:
# remove the above line if you edit this file

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

Why is this not working and what must I do to get the IP address to stick after reboot?



Jeremy Davis's picture

The commandline software that we provide (called ConfConsole - dark blue background, light blue headings, grey text box, with black text) should display the IP address of your VM. By default that configures networking to use DHCP. But it can also be adjusted to set a static IP.

My guess is that you used some other method to set a static IP and for some reason ConfConsole settings overrode it and gave your server a new DHCP IP when you rebooted (hence why you couldn't connect to it).

Assuming that I'm right, log in via SSH and configure your networking within ConfConsole. It should be running by default and greet you when you first log in. If it's not, then you can access it by simply typing "confconsole" (without the quotes).

If I'm wrong and you are using ConfConsole to adjust your network settings, can you please provide some more information. E.g. where/on what your server is running (VirtualBox VM, bare metal, etc.) and anything else you may have tweaked or adjusted in the meantime.

PS I have just had a closer look at the RPi-StackExchange post you linked to, and I wonder if perhaps we should adjust how we currently do things? As a general rule, it seems to still work fine for most users as is. However, from my reading of the highest voted answer, it appears that we are still using the "old" way of doing it. If that's the case, ideally we should do it in a way that is consistent with other Debian Jessie documentation...

Add new comment