Forum: 

Hub Support Restore

Hello,

Firstly the support link on the turnkey hub is not working.

Secondly I am trying to do a test restore to another virtual machine. The restored target already has an existing installation from march 2016 and I am trying to restore my latest backup from the live machine dating DEc 2016.

When I run the restore to the target I get a bunch of errori regards to postgress

ERROR: database "jira" already exists
ALTER DATABASE
You are now connected to database "jira" as user "postgres".
SET
SET
SET
SET
SET
SET
CREATE EXTENSION
COMMENT
SET
SET
SET
ERROR: relation "AO_21D670_WHITELIST_RULES" already exists
ALTER TABLE
ERROR: relation "AO_21D670_WHITELIST_RULES_ID_seq" already exists
ALTER TABLE
ALTER SEQUENCE
ERROR: relation "AO_38321B_CUSTOM_CONTENT_LINK" already exists

and so on ..

I would appreciate some more detailed documentation about how to run a restore process.

regards
Paul

 

Just to add the restore completed but the database was not updated.


Jeremy Davis's picture

Apologies to hear that you had issues using our Hub Support link. Can you please double check that you do not have any content blockers (such as adblockers or tracking blockers) or anything that messes with javascript when you access the Hub. That is the most common cause of the issue you experienced. A quick and dirty check is to use "incognito/private" mode (as usually all your extensions/plugins are disabled by default).

Regarding your TKLBAM restore error, that doesn't seem right! I'll need to escalate this to my colleague Liraz who is the developer of TKLBAM and see what he thinks.

In the meantime, as a workaround, perhaps you could try manually dropping the "jira" DB (and any other DB that is erroring) from your old instance and then retry the restore? Obviously, don't do that on your production machine (just in case something goes wrong). But assuming the data in this instance is out of date anyway, worst case scenario it still won't work...

Post new comment