Chuckak's picture

Deployed fileserver OVF file on VMware ESXi 6.5 host.

Added 2nd hard disk 1TB in VMware VM settings.

Booted fileserver and configured network all OK.

Attempted to create partition on 2nd scsi disk.

Tried Linux and NTFS both error out with invalid cylinder 0.

Tried Thin Provisioned and Thick Provisioned in VMware for the hard disk.

I am dead in the water as I am a Linux noob.

Jeremy Davis's picture

Without properly knowing exactly what you have done so far and what the exact outcome of your steps were, it's hard to know what went wrong...

Also, by default, our OVF install uses LVM. We have a dated, but still relevant blog post on how to add additional space via adding a new volume to the LVM here.

If you'd rather not go that route and just want to manually add a new volume as an independent volume, then steps are something like this:

  • add new vHDD in VMware
  • partition new volume (I use fdisk)
  • format partition with filesystem
  • mount filesystem
  • add new partition to /etc/fstab (so it auto mounts on reboot)
  • reboot and test it works as expected

    Under the hood, TurnKey is Debian (v14.x = Debian Jessie) so any docs you find that are relevant to Debian, will be relevant to TurnKey. E.g. here is a fairly generic Debian/Ubuntu tutorial which looks like it should work ok (I haven't tested, but looks good on face value).

    If you have no joy with any of that, please do not hesitate to post back, but please give a bit more specific info on what you tried and what response you got. Ideally use the commandline, then you can copy paste the full text of error messages etc.

  • Chuckak's picture

    I installed Fileserver as it has a GUI interface.  Since I can barely spell command line.  What is the point of the GUI then?

    I have added the disk in VMware and the GUI sees the second disk.  The GUI format comes up with the 1st cylinder is invalid.  Are you saying the GUI format commands do not work and I have to manually do all of this?

    The default format shows up as 1 through the total amount of cylinders.  Should the first number be 2048?

    Since my intent is to use this as a Windows domain client accessible file server what format type should I be using on the data drive? I do not want to share anything on the boot drive.

    Jeremy Davis's picture

    And at least in theory, Webmin should be able to do what you want. It's more that I am not very familiar with it.

    FWIW Webmin actually uses the commandline under the hood. But on Linux, there are often multiple tools/ways to reach a desired ends. As Webmin is written to work on a whole range of OS, it only uses fairly generic tools, whereas IMO sometimes there are better tools for the job.

    Personally I find the commandline much more powerful and easier to work with. As noted, it often has multiple ways to reach a similar ends (so if something doesn't work, you can try something else). I also find it much quicker to use, and much easier to share with others, or note for next time (simply copy paste the commands somewhere). I find it also generally gives much more useful error messages. Obviously, YMMV, and I understand that on face value it can seem daunting.

    Please feel free to continue as you are, but I would recommend that the best resolution to achive your ends, would be to increase the size of the current volume, or add the new volume to the LVM (as I suggested in my last message). That may also be an option via Webmin, but I don't recall and don't have time to check ATM. FWIW you can add an unformatted, unpartitioned volume to an LVM (the extend the partition across the LVM).

    Another option would be to manually create a new VM (with the disk size you desire right from the start) and install from the ISO (instead of using the OVA - with a preconfigured vHDD).

    To specifically answer your question; modern HDDs (including virtual HDDs) should not need any cylinder info when formatting (because they actually don't use cylinders). So using whatever the defaults are should be fine. Although if that isn't working for you, perhaps try leaving a 2kB gap at the start (i.e. 2048 bytes) as you suggest.

    Seeing as you intend to access the disk via Windows file sharing, you shouldn't need to use any specific filesystem (the Linux default should be ext4 - which should be fine).

    I hope that helps...

    Add new comment