Chuck W's picture

Hello all,

I have managed to get the Dokuwiki VMDK running, and love Dokuwiki. I want to install the upgrade Plugin by Andreas Gohr and have found it using search, but I don't have an option to install it. Instead the right column says Plugin directory is not writable.

What do I have to do to have the option to install plugins? 

Please keep in mind I do not know a lot about linux.



Jeremy Davis's picture

FYI there is a feature request to do that. The code has been developed and merged, but the applaince hasn't yet been rebuilt to include it. That will happen soon hopefully.

In the meantime, you may find the docs that were also developed regarding file permissions useful?! By default the appliance is currently locked down (as per best practice) but to support the upgrade plugin they need to be relaxed. So the next release will ship with relaxed permissions by default. But those docs will allow you to lock it down again if you wish.

Just in case it's not obvious, on the current appliance follow the last bit on that doc page (to loosen permissions), then you should be all good.

Chuck W's picture

Hello Jeremy,

First of all, thank you for the time response. It is much appreciated.

Second, this worked like a charm. I was able to install the plugin and it appears to be working!

Again, thank you!

Jeremy Davis's picture

Thanks for confirmation that it worked for you.

Add new comment