Psilospiral's picture

Greetings Forum:

I have Turnkey File Server up and running in a Proxmox Container.  Samba shares are working without a problem - I am copying files from various Win clients on the LAN over to the Turnkey File Server shares.

Now I am trying to mount the same Turnkey File Server shares from a Debian machine.  When I enter:

	showmount --exports 192.168.1.100

with 192.168.1.100 being the Turnkey File Server IP, I receive:

	clnt_create: RPC: Program not registered

However, when I enter:

	showmount --exports 192.168.1.200

with 192.168.1.200 being the QNAP server with NFS enabled, I receive a listing of all of the shares available to mount.

What am I doing wrong or have not enabled in Turnkey File Server?!?

Forum: 
Jeremy Davis's picture

If my assumption is correct, then you need to have NFS installed on the host, plus there are some config changes (for both the host, and the guest) required. There is a Proxmox forum thread which covers this, plus google turned up a gist that looks promising (although I haven't tested it myself; 5 stars suggests that others have found it useful)).

FWIW, I generally use SSHFS to share between Linux machines (containers, VMs and/or bare metal machines). As the name suggests, it requires SSH to be installed on both host and guest, SSHFS itself only needs to be installed on the guest (i.e. where you intend to mount). It's worth noting that non-root users can mount remote directories via SSHFS, so long as they have appropriate permissions to the mount point. Sudo may be required to unmount though.

Psilospiral's picture

Hello again Jeremy:

Yes, nfs-common is already installed on the PVE host as well as the Debian client.  Thank you for the link in the PVE forum - it referenced another thread indicating a syntax change in the PVE config since 2016.  When skimming that thread, I noticed a user indicating that after he enabled the "nesting" option, he was able to mount NFS.

Within the Turnkey File Server container (CT), you go to Options>Features and check the box next to Nesting.  I already had two more boxes in here checked: NFS and CIFS.  After restarting the file server CT and going to my Debian client, this is now what I get:

	showmount --exports 192.168.1.100
	Export list for 192.168.1.100:
	/srv/homes        192.168.0.0/16,172.16.0.0/12,10.0.0.0/8
	/srv/storage    192.168.0.0/16,172.16.0.0/12,10.0.0.0/8
	/srv            192.168.0.0/16,172.16.0.0/12,10.0.0.0/8

But when I enter:

	mkdir /mnt/test
	192.168.1.100:/srv/storage /mnt/test

I get:

	bash: 192.168.1.100:/srv/storage: No such file or directory

 

 

Jeremy Davis's picture

I'm not very experienced with NFS, but looking at the command (and the error message) it appears that you aren't preceding the info regarding what you want mounted, with the mount command! :)

Perhaps try this instead:

mount 192.168.1.100:/srv/storage /mnt/test

Assuming that works as expected, you'll likely want to add it to your fstab (so it automounts at boot time). Google suggests that the fstab line should look like this:

192.168.1.100:/srv/storage /mnt/test           nfs          rw           0    0

I hope that helps.

Psilospiral's picture

Jeremy:

Good grief.  I was entering on the command line what I meant to enter in the fstab!  When I place my command (without the "mount") in the fstab and enter

	mount -a

on the command line, I'm mounted and able to access the share!  Let me repeat: good grief.

The reason I went to a Debian machine with this test was to make sure I have NFS configured properly in TKL File Server for some Debian clients I plan to network with NFS.  On a Win client on the LAN, I can r/w to the TKL File Server shares without issue via CIFS/Samba.

From a Debian client, I can now access the share served by the TKL File Server via NFS, but I cannot write to it when logged in as root.  When I exit and return to a normal user, I can indeed write to the share.  This caught me off guard - I thought the root user was super and could access/write to all shares!?

So now it looks like I'm just down to fine tuning GID/UID in TKL File Server...  I have not altered any "Unix" user settings within TKL yet, aside from creating a single user under System>Users and Groups (within Webmin) and then clicking "Convert Users" under Servers>Samba Windows File Sharing...

 

Add new comment