Lee Chambers's picture

Hi all,

First time installing wordpress using the turnkey linux, have only installed it on windows before.

 

However i dont know if im just being a bit daft but ive tried multiple times now with a fresh install and right out of the box without any changes made the stylesheets dont seem to be loading ... or any images for that matter on the default theme.

 

Am i missing something or is there a bug .. could someone else try a fresh install on a vm and see if you have the same result .. ive tries editing the urls in the config file and database to no avail ... setting the permissions to 0777 throughout the wordpress folder to test ... no avail ... im now at a loss 

 

Any help would be appriecated 

 

Thanks

Forum: 
Tags: 
Cyberben's picture

If you can get into the general settings, check (and correct if you have to) your:

WordPress Address (URL)

 

Site Address (URL)
Lee Chambers's picture

hi, thanks for replying

i have checked these as i know they can cause issues, also checked in the database as well 

i doesnt seem to work on a fresh install which to my understanding the config is defaulted to any url

even editing the config to just use the the 1 url and site as well as the database doesnt change anything.

 

im totally at a loss on this, apart from that fact there could be some kind of bug but even trying version 14 its exactly the same, hence i was wondering if someone else could try a fresh install in a vmware vm to see if the same results appear

Cyberben's picture

I did an turnkey-wordpress-15.3-stretch-amd64 install today and it doesn't look like its using a wordpress default theme that would be in place if you had done it all from scratch.

I did a wordpress update by accident before looking into things but

I think perhaps they adjusted the original themes? Non of the themes includeded seem very involved and I dont see any image placement errors.

 

Lee Chambers's picture

Hi,

 

I think your exactly right after much time looking last night, it does seem that all the preinstalled themes seem very blank.

If anyone else comes across this uninstall all themes before updating, do the wordpress update and then install a non default theme and everything looks as it should.

Must just be an issue with certain themes, but thanks for your time in looking into it, i now havs everything installed and working well with SSL 

 

Thanks

Jeremy Davis's picture

The "twenty nineteen" theme is pretty bland (with no pics or anything), so that's expected by default. I haven't tried uploading any pics, so I can't really speak to that, but I did enable the "twenty seventeen" theme. That has a big landing page picture that takes up the full page by default and that seemed to display fine?!

FWIW, often the best way to check why pictures aren't displaying is to use your web browser's built in "developer tools". In Google Chrome it's <Ctrl><Shift><i> but it should also be an option in Firefox, Safari and Edge too (not sure on key shortcut, but you should find more info via a google). With that open, look for errors in the console. Pictures that aren't showing might be a 404 (file not found) or perhaps a 503 (permission denied), or perhaps something else altogether?!

Also, the default commandline login on TurnKey appliances is the root user. However, the webserver account (www-data) needs to have read access to display pictures, etc. We do set www-data as the owner of all the WordPress files by default, but changing things while running as root will likely change that. I do hope to develop a nice CLI tool to make that easier in the future, but for now, probably the easiest way to go is to manually give www-data full ownership of the WordPress files after making any changes via commandline. You can do that like this:

chown -R www-data:www-data /var/www/wordpress
Lee Chambers's picture

Indeed this is true .. i guess the part that threw me off from the start was the fact looking at the themes thumbnail image to how its actually displayed is somewhat very different .. hence it just looks as if the css file is not loading, as i had this issue on a previous windows wordpress install. Have to say .. i much prefer the turnkey installation for this ... it runs so much faster and and more responsive than a windows installation by far. Im actually starting to prefer linux installs alot its just a shame i have no clue what im doing with linux to use it more regular. This is where im grateful for turnkey linux, simple for the end user and it just works the little gui for installation is a massive help for newbies aswell. Thanks for the help and keep up the great work.
Lee Chambers's picture

Thanks for the help and the time to look into it.

I did put another post on but i forgot to log in so now its pending approval.

Why the made the new default themes so bland is beyond me as they look nothing like there thumbnail pics, but never mind.

Now if there was a turnkey version of ms exchange server that would be all my prayers answered.

Turnkey is great ... keep at it 

Jeremy Davis's picture

Thanks for your kind words Lee.

If you have any further questions or concerns, please don't hesitate to ask.

Good luck with it all.

Also, once you get your head around Linux a bit more and feel like having a crack at a ms exchange server replacement, please don't hesitate to ask for assistance and/or guidance. Perhaps we could look at adding something to the library?! There are a few possibilities floating around, but none that I've tried myself.

Add new comment