Murphy's picture

Hello all,

I have a problem with cache and the Nimble Page Builder.
Every time I open it, I get this error message:

- no plugin for cache installed
- latest turnkey wordpress
- wordpress 6.2 (also before the message)
- memory 6gb
- swap 4gb
- disk 12 gb


what do i have to change ?

Jeremy Davis's picture

I am unclear on exactly what cache plugin it's referring to?

If you don't have any WordPress cache plugins installed, then I can only assume that it's referring to the PHP OPCache?! The OPCache can be disabled by editing the main PHP config file, aka the 'php.ini' file. It can be found at /etc/php/X.Y/apache2/php.ini (where X.Y is the PHP version, by default TurnKey v17.x comes with PHP 7.4). The setting you need to change is "opcache.enable" and to disable set it to '0'. I.e. after you've adjusted it, the line should look like this:


Also please note that the default settings are often commented out (i.e. have a leading ';' so the line is ignored). That prefix also needs to be removed.

To make life easier, here is a one liner:

sed -i "s|^;*\(opcache.enable\) *=.*|\1=0|" /etc/php/?.?/apache2/php.ini

Note that will work for any version of PHP.

After disabling, you'll need to restart Apache to reload the updated config:

systemctl restart apache2
Murphy's picture

Hello Jeremy,
that was exactly what I was looking for.
It worked straight away.

I had previously used the Lamp version.
Unfortunately I couldn't get the mod_rewrite module to work (because of the permalinks). I don't have that with Wordpress.

Now everything runs perfectly and I would like to praise you for your wordpress version!

Jeremy Davis's picture

Excellent news! Glad to hear that helped.

I'm not sure why you couldn't get mod_rewrite to work on the LAMP appliance? It's pre-enabled by default on the WordPress appliance, but it should be pretty easy to enable on LAMP (or any other appliance that uses Apache as the web server). FYI, this is the command to enable it:

a2enmod rewrite

Please feel free to try that yourself (on your WordPress appliance - where it's enabled already, it will tell you so - so won't do any harm).

If it wasn't already enabled, it will tell you to restart Apache (to apply the updated config). For completeness:

systemctl restart apache2

You probably don't need to disble it, but while I'm here, disabling it is just as easy:

a2dismod rewrite
Murphy's picture

Unfortunately, I can no longer understand why it didn't work in lamp. probably it was me ?!

i had not had to deal with it before, but for our business i wanted to try it now with google friendly url.

here i had then tried a dietpi and a normal wordpress installation with ubuntu on the local server.
I was too stupid to activate mod_rewrite with these commands and shot up the Apache configuration every time.


But I also noticed something else:
the plugins, updates and themes (although they are set to automatic) are not updated.

Do you have a tip for this (I think it's about the right cron script)? 

Add new comment