leogrande's picture

I have tried to deploy some apps like observium and wordpress on the TurnKey LXC to no avail.

My inithooks_observium.conf for observium:

export ROOT_PASS=<password>

export DB_PASS=<password>

export APP_PASS=<password>

export APP_EMAIL=some@email.crz




lxc-create -n observium_lxc -f /etc/lxc/bridge.conf -t turnkey -- observium -i /root/inithooks_observium.conf

In my case the original /usr/share/lxc/templates/lxc-turnkey caused an error with the observium/wordpress package downloading.

So I decided to use lxc-turnkey from here.

I have added 14.2 to:

 case "${tkl_version}" in
    13.0)    signature="${image}.sig";;
    14.0)    signature="${image}.sig";;
    14.1)   signature="${image}.sig";;
    14.2)   signature="${image}.sig";;         
       *)    signature="${image}.hash";;

but the version 14.1 was downloaded not the latest.

I was able to start new containers. Both containers failed to connect to mysql server (error establishing a database connection).

I do not know whether this is an issue with lxc-turnkey template or with something else.

Can't blame the TurnkeyLXC itself, I successfully deployed for the test purposes an ubuntu container on it.



Jeremy Davis's picture

We've swapped to using a .hash file instead of a .sig file so either change your new 14.2 line to be signature="${image}.hash";; or just remove it ('*' is a catchall wildcard).

Then you need to specify the version using the -v switch, like this:

lxc-create -n observium_lxc -f /etc/lxc/bridge.conf -t turnkey -- observium -v 14.2-jessie -i /root/inithooks_observium.conf

FWIW we had hoped to include a script for the new (v14.2) release of the LXC appliance (will be released within the next week hopefully) so it automatically downloads the latest version, but we didn't quite get there. We hope to include that for the v15.0 LXC appliance when we get there.

leogrande's picture



I have followed your recommendations and the version 14.2-1 was downloaded. But the version is not my big concern. I am still getting the next error when I am trying to open observium:

DB Error 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)




Jeremy Davis's picture

Sorry we're currently snowed under at the moment. I was in a bit of a rush, so sorry I missed that point.

I see below that it seems to have resolved itself though?! Or did you manually create the socket?

Also FWIW we will be releasing a new version (v14.2) pretty soon hopefully.

It seems a bit weird either way really. FWIW I test (albeit pretty quick and dirty) all the appliances prior to release. I actually build to LXC and test on Proxmox (built from the exact ISO we are about to release).

Seeing as you've got it going now, hopefully everything continues smoothly. If you do come across something like this again, if you can give us instructions on how to reliably reproduce it; we can fix it. Intermittent issues can be a whole other story, but please share. The more bug reports we get, the better we can make TurnKey! :)

leogrande's picture

It works now. For some reasons /mysqld/mysqld.sock has not been created initially. 

leogrande's picture

I believe it didn't work for me when I started a container not in daemon mode without the -d switch. After this I have recreated an observium container several times and started it in daemon mode with no issues whatsoever. But that initial missing of /mysqld/mysqld.sock is weird I agree and initially I have created them manually and it worked out.

leogrande's picture

My setup is: Ubuntu 16.04 QEMU/KVM

Add new comment