Single domain  version 41.2 Nginx php appliance. All updates applied.  Try to do s ingle cert I get

 

[2017-12-04 15:48:03] dehydrated-wrapper: WARNING: Check today's previous log entries for details of error.
  + ERROR: An error occurred while sending post-request to https://acme-v01.api.letsencrypt.org/acme/new-reg (Status 400)

Details:
{
  "type": "urn:acme:error:malformed",
  "detail": "Provided agreement URL [https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf]",
  "status": 400
}

[2017-12-04 15:49:08] dehydrated-wrapper: FATAL: dehydrated exited with a non-zero exit code.
[2017-12-04 15:49:08] dehydrated-wrapper: WARNING: Something went wrong, restoring original cert & key.
[2017-12-04 15:49:09] dehydrated-wrapper: WARNING: Check today's previous log entries for details of error.

Forum: 
Jeremy Davis's picture

Apologies on my really slow response. I've been flat out behind the scenes.

Anyway, thanks tons for taking the time to report this. This is currently a known issue. Resolving it is one of the things I've been working on in the background! :)

As I see you've discovered, this issue was discussed in another thread. I'll catch you over there. :)

Mike Jacobson's picture

Jeremy --

Did this error get fixed ?

Just tried to use your scripts to get Let's Encrypt digital certs from the OwnCloud Appliance and received error "...while sending port-request to https://acem.V01.letsencrpyt.org/acme/new-reg (Status 400)".

Please advise.

Thank you

Mike

Jeremy Davis's picture

It's been fixed, but unfortunately, it's not yet fixed in the actual images... :(

I've been funnelling all my energy into the next major version (it's so close now...) so the current images haven't had any love for a while...

Unfortunately, the fix isn't quite as easy as I might have liked, although it is fairly well documented. Please see the Confconsole v1.1.2 release notes for instructions on how to install/update. It's fairly well battle tested now, so it should "just work".

Apologies that it's not ideal, but hopefully that'll get you up and running. If you have any issues or questions, please don't hesitate to post back.

Add new comment