Daniel's picture


I have a LAMP server installed, I use it for TeamSpeak and now want to have a webpage on my domainadress.

The domain.xx:12321 works but when I tried to access

domain.xx the error is:

Unable to connect


How and where do I start serch for errors?

Jeremy Davis's picture

Webmin (port 12321) and Webshell (port 12320) are not served by Apache. So the fact that Webmin works is only confirmation that your DNS mapping is configured properly for your domain and that your server is running (and of course that Webmin is running too).

So first thing to check is if Apache is running:

service apache2 status

If that says that it's running (i.e. in v14.x IIRC it should be "active (running)") then that's a good start. If not then I suggest that you try starting it:

service apache2 start

If that doesn't solve things, checking the error log is probably the next thing to do! Apache error log can be found: /var/log/apache2/error.log .

Hopefully that will give you a really good idea of what is going on. If it doesn't make much sense to you, please feel free to post it and I'll have a look.

Perhaps if you share a bit more about the setup I might have other ideas... E.g. what TurnKey version, where it's running and on what platform (e.g. local VirtualBox VM, local bare metal, remote VPS, etc).

Daniel's picture

Oh thanks.
I got this error:

> service apache2 status
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
  Drop-In: /lib/systemd/system/apache2.service.d
   Active: failed (Result: exit-code) since Sun 2018-07-01 21:14:30 UTC; 4 days ago
  Process: 507 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Jul 01 21:14:30 lamp apache2[507]: Starting web server: apache2 failed!
Jul 01 21:14:30 lamp apache2[507]: The apache2 configtest failed. ... (warning).
Jul 01 21:14:30 lamp apache2[507]: Output of config test was:
Jul 01 21:14:30 lamp apache2[507]: AH00526: Syntax error on line 5 of /etc/apache2/conf-enabled/mumble-django.conf:
Jul 01 21:14:30 lamp apache2[507]: Invalid command 'WSGIScriptAlias', perhaps misspelled or defined by a module not included in the server configuration
Jul 01 21:14:30 lamp apache2[507]: Action 'configtest' failed.
Jul 01 21:14:30 lamp apache2[507]: The Apache error log may have more information.
Jul 01 21:14:30 lamp systemd[1]: apache2.service: control process exited, code=exited status=1
Jul 01 21:14:30 lamp systemd[1]: Failed to start LSB: Apache2 web server.
Jul 01 21:14:30 lamp systemd[1]: Unit apache2.service entered failed state.


I suppose I dont have the LAMP image. I have Mumble image.

Daniel's picture

Remove Mumble packages and now it start.
Thanks for all the help.


Jeremy Davis's picture

Glad to help and great to hear that you've got it up and running.

FWIW, you probably didn't need to get rid of Mumble if you didn't want to (although it sounds like it doesn't matter to you...).

Just in case, here's some extra info. Judging from your output, it was complaining about the 'WSGIScriptAlias' command somewhere in your Apache conf. If you don't need WSGI, you could either comment it out (add a '#' to the start of the line that has WSGIScriptAlias) in the relevant conf file. Or disable that particular conf altogether ('a2dissite name-of-site'/'a2disconf config-file'). If you did need/want WSGI, you just have to enable it (and/or possibly install it if it's not installed). To do that: 'a2enmod wsgi' and/or 'apt-get install libapache2-mod-wsgi'.

Anyway, good luck with it all. :)

Add new comment