sergioarnal's picture

Hello, how do I update the webmin 1.880 to 1.930 to install modules?

Forum: 
Jeremy Davis's picture

You should find all of the core modules are installable via apt. The packages are named "webmin-MODULE_NAME", where "MODULE_NAME" is the name of the .wbm.gz file. E.g. if you wanted to install the CD burner module ('burner.wbm.gz'), you could do that like this (note if you are not running as the user 'root', you'll need to prefix 'sudo' in front of all the lines I quote below):

apt update apt install webmin-burner

Hopefully that will give you what you're after.

Having said that, I haven't explicitly answered your question on "how to update webmin". Personally, I would just do the above, but if you really want to update Webmin (or need a module that for some reason we haven't packaged) then I suspect that the best way to do that would be to remove the current webmin install and re-install direct from upstream (i.e. Webmin themselves). I haven't tested that for quite some time now, so I'm not 100% sure how it will go, but I would expect it to work fine.

Like anything potentially destructive, I suggest that you ensure you have all your data backed up and perhaps even a "snapshot"/"clone" of the full filesystem before attempting this. Then worst case, if everything goes pear-shaped, you can get back to where you are now.

So first remove the current webmin:

apt remove webmin

Then download the latest deb file from the Webmin downloads page. E.g. to download the current (1.930) version:

wget https://prdownloads.sourceforge.net/webadmin/webmin_1.930_all.deb

Ideally you should double check the GPG signature of the file too (as suggested by Webmin - to ensure that the file you downloaded is the file it says it is) but I won't go into that right now. Then install the new deb like this:

dpkg -i webmin_1.930_all.deb

Fingers crossed, that should all "just work". If not, you could just try rebooting and see if that resolves it. If you still have issues, please feel free to post back.

Nfo's picture

I was looking for how to update the module to the latest version to see if I can correct the webmin's vulnerability ... I have followed these steps and in my gitlab it works perfectly:

apt remove webmin
wget https://prdownloads.sourceforge.net/webadmin/webmin_1.930_all.deb
apt --fix-broken install
dpkg -i webmin_1.930_all.deb


Now it is much easier to update gitlab from the webmin, it is no longer necessary to do it by commands ...

Thanks Jeremy

Add new comment