dentpusher's picture

super noob here, got a fresh install of proxmox then created turnkey zoneminder container. install went fine ive practiced in virtbox on a windows machine so knew what to expect, after install first i went to root and confconsole and setup a static ip, didnt do anything different and also tried dhcp aswell. either way i can ping the ip address just fine however cant access ip address in my browser it times out. so i cany get to zoneminder gui on the proxmox container.

i have no idea what i missed, ihave done turnkey zoneminder on baremetal and in virtbox successfully. now this is first attempt on this AMD server pc i built to run proxmox so maybe its the setup???

msi x470 gaming

ryzen 7 2700x

24gb gskill ram

nvidia gt9800 for graphics during proxmox install

120gb boot ssd

1tb m.2

3x 1tb ssd

2tb hdd

4tb hdd purple

settings in bios are set for vm. not to complicate things but my netgate 1100 firewall shows the ip address for the zoneminder container, gives it a lease when in dhcp plus i can access and run proxmox from my laptop so dont think its the netgate firewall blocking anything its all set to acccept all for now...

im ok with command line but was thinking turnkey does some of that for you like mysql or do i have to modify mysql with turnkey.

any help or direction would be great im kinda bangin my head against the wall.

Jeremy Davis's picture

Hi there and welcome to TurnKey. Unfortunately it looks like the forums ate your post.It does that occasionally. I have tried to resolve the issue, but PHP isn't my language of choice and I couldn't work it out. We do have someone who has more expertise going to have a look sometime soon.

Regardless, our Zoneminder appliance should "just work". Even if something is wrong within the container, I'd expect you to actually get some sort of error in your browser (rather than not connecting at all). So the first thing I suggest is double check your container's network config. Then test connectivity via ping. If that appears to work ok, then I suggest trying to log in via SSH. If that fails, my first guess is that you may have an IP address conflict.

If you can log in via SSH, then double check that Apache is running:

systemctl status apache2

And listening on the appropriate ports:

netstat -tlnp

Then look for ports 80 & 443. If they both show up, then Apache is working. Perhaps also double check that Webshell and Webmin are also running (stunnel4 running on ports 12320 & 12321 respectively).

Please feel free to share any further info.

Add new comment