Vadim Pavlovich's picture

Hello, we came accross an error with quite popular page builder plugin - Visual Composer.

When plugin is enabled - we can't edit or create any page. As soon as I click EDIT I get white screen with error:


This page isn’t working didn’t send any data.



I was trying to enable logs in wp-config.php by adding following:

define('WP_DEBUG', true);

define( 'WP_DEBUG_LOG', true );

define( 'WP_DEBUG_DISPLAY', true );


However errors are not displayed in browser and log file is not created in root directory. I will appreciate any help on that,



Jeremy Davis's picture

Generally PHP issues should show up in the default Apache log: /var/log/apache2/error.log

Hopefully you should see any issues logged there. If it's not showing enough detail, then please try setting the error reporting level in PHP by updating the php.ini file (IIRC it should be /etc/php5/apache2/php.ini). This should probably do the trick:

error_reporting  =  E_ALL
display_errors = On

Note that lines that start with ';' are ignored, so if you just add those lines right at the bottom, that should do the trick. Then restart Apache:

service apache2 restart

Good luck!

Vadim Pavlovich's picture

Yes, there was an error:

Error: AH01328: Line too long
Explanation: Improper handling of newlines by mod_substitute could cause errors.

And the solution is decribed here:

Add following line to WordPress .htaccess file:

SubstituteMaxLineLength 10m
Jeremy Davis's picture

Great stuff. Although I'm not clear if the fix worked for you?

If so, that's even better!

Otherwise, perhaps try disabling mod_substitute (unless you need it for something else). By default it is what adds the TurnKey credit footer.

To do that (off the top of my head; may not be quite right):

a2dismod substitue
service apache2 restart

Add new comment